Executor start process failed, reason System.Runtime.InteropServices.COMException (0x80070001)

I get this error whenever I run a process in Orchestrator. It happens on different orchestrator accounts and on different robots. At the same time I can run the processes locally. The problem occurs only when they are run in Orchestrator. Any advice?


Could you provide more information about the version of UiPath and Orchestrator you are using?

Hi, this is what I found:


Can you please describe the environment and what you are trying to setup?

What type of windows are you using?

Do you have multiple robots? Are they on the same machine?

In the robot Settings .> Runtime tab, what is the value for “Login to console” option?

Can you create a manual (using windows remote desktop connection tool) connection to the target machine using that user?

I’m using Windows 10. I have only one robot on one machine. I have a basic development environment. The value to “Login to console” is “no”. I’m trying to set up a very basic process with a message box popping up, just to see that it works.

It used to work, but then it stopped and it seems to be not working on all the possible processes and orchestrator accounts.

I dont know how to check manual connection to the target machine. By the target machine do you mean the computer where UiPath Studio is installed?

Yes, the target machine is the machine where the robot that you want to run the flow with, exists.
To check the connection, go to
Start > mstsc > enter > show options > add the ip or address of the machine> add the domain\username and password of the user and press Connect


Or are you trying to run a job from Orchestrator on the VM you are currently developing on ?
In this case, make sure that “Allow remote connections on this computer” from System Properties is enabled and that the user is added in the Remote Desktop Users:

Yes, I’m trying to run a job from Orchestrator on the machine that I am developing on. Do you mean to add the windows user that I use? In that case the user already has access.

What about if you use Login to console = YES in the Settings tab ?

Unfortunately, I get the same error

I checked the issue reporting application and there seems to be an open issue with this error code (COMException) 0x80070001.
I will keep a close eye on it and and come back with a solution once it is resolved.
In the meantime, can you please tell me what type of user you are using? Is it domain user, it it local user?

Also, I see that you are having a 18.2.3 robot, enterprise.
The robot runs as a windows service ?
Can you please check if you have both 18.2.3 enterprise and any other version of community edition ? (You can check this in the uninstall menu from Control Panel if more than one instances of uipath appear)

I’m using domain user.
I have the following service running: UiRobotSvc
I have only one UiPath version installed on my machine (8.2.3, enterprise)