Excel File opened but not shown in desktop screen, hence hotkey not sending right

How to ensure that when an excel application scope is being used, the excel file is shown in the desktop screen.
From the image attached below, my UiPath is running the excel sheet through the taskbar. Due to that, my hotkey is sending not sending to my excel file. May I know how the Excel file can pop up so that my hotkey can be sent?

Hi ,

It depends upon what type of activity you use. There are 2 type of excel activities

  1. System( which does nt require ms excel to be present, hence they didnt open excel sheet and work in back ground)
  2. Integration ( which require ms excel and opens the excel sheet. These are inside excel application scope activity).

And even if you are using integration activities then try using show window so that excel come on front and then use send hot key activity

Activate?
UiPath Activities Guide
or ‘activate’ ‘sendWindowmessages’ option
send hotkey

hi @sumire

Welcome to the community!!! :slight_smile:

Please go through the following activities

This has an option as “Visible” in it, so if you enable it.
It will allow you to view the excel while the robot is working!!!

Happy learning :slight_smile:

sorry for my poor english
I just want to suggest

Okay Thank You!