Excel Application Scope 'Visible' Not Working

I’m trying to launch an Excel document, Refresh All to update links, and then extract the data in the worksheet.

Whenever it launches, the Excel icon just blinks in the toolbar, and Excel does not come to the foreground (even though Visible is checked). I tried to get around this by just using hotkeys to refresh the data, and specifying the target as the Excel file. However, the Send Hotkey activity fails with a ‘Timeout Reached’ error. I’ve played with the selector, and it is definitely valid even with Excel in the background.

What is a reliable way to bring the app into the foreground? I’ve seen this question so many times and nothing I have tried works (Attach Window, Maximize Window, Activate Window).

1 Like

Fine
we can use GET ACTIVE WINDOW activity which will bring the active application to the foreground

Cheers @bencod

@bencod It is difficult to interact with Excel using Excel application scope, Use start process or Open application so that you get reliable selectors . you can even write a simple VB script to auto update links once you open the excel file.

I’m having the exact same issue! I’ve tried everything from attach window to reinstalling the Excel package, and nothing changed. Did you manage to resolve this?

1 Like

OK. So I just managed a work around. Added a “click” to the Excel app in the windows toolbar. Not ideal, but working at least.

I wasn’t able to get clicks to work. My solution was to just put all of the actions into a VBA script in a txt file and call Invoke VBA.

I also had this issue, kindly share the work around. Thanks.