Excel changes not saving

For some reason, every automation I do using excel files is not saving the changes in the files after the execution is done. The rest of the automation works just fine, I can see each step working as they should, but when I open the file it is like nothing has been done.

The “save changes” options is checked and the “read-only” option is unchecked, so I’ve no idea why this is happening

@olwrrb is it file containing pivot table? Or it is simple excel file.


If you use not Excel activity such as Write Cell etc. but UiAutomation : Click, Keyboard shortcut etc, auto save won’t work. Please explicitly save workbook or use Excel activity like Write Cell at the end of the scope.


simple file

I’m only using excel activities, no other automations like click or shortcuts

@olwrrb can you show us exact activities and their properties which you are using to save file.


Does this occur in Studio or Assistant? If latter and try to modify xlsx file via relative path, file which exists under c:\users\[username]\.nuget\packages\[packagename]\[version]\lib\net461 (or net6.0-windows7.0) will modified.
Can you try to check the above path and/or use absolute path?


This has happen to me before, but this is the most recent project. Right now I’m doing the “Excel Automation With StudioX” course, the empty values are the ones where the input would be the column inserted by the first activity, but it doesn’t save.

I could save it manually to finish the automation, but I want to fix the issue.

I’m a new user, so it just lets me put one image per post

Hi @olwrrb ,

Possible to share your workflow so I can check? Thanks.

Kind regards,

Use at before closing scope at the end save excel activity this will resolve your problem

Hi @olwrrb,

  • Verify that the changes are actually being made in the Excel file. You can use the “Write Line” activity to print the values of variables or cells to the Output panel, or use the “Message Box” activity to display them on the screen, to check that the changes are being made correctly.
  • Ensure that the “Save” activity is included in the automation flow and that it is being executed correctly. Make sure that all the required parameters are being set correctly, such as the file path, file format, and overwrite option.

Hello Oliwer,

From this screenshot it shows you are telling the bot what to write but have not told it where to write. If you look at the red alerts you can see that there are errors. In the vlookup you have not defined the range.



Here is the zipped project folder. I tried changing the path and adding a “save excel file” but it still didn’t work

Hi @olwrrb ,

I tried accessing the link you shared but it was empty.

Kind regards,