Noob Use Excel question

Hi - I am building a proof of concept, super simple. Just need to grab an excel file (report1) and append the data to a master excel file (MasterFile).

I currently have this in 4 steps

  1. Use excel file (MasterFile)
  2. Use excel file (report1)
  3. Append range from Report1 to MasterFile
  4. Save the MasterFile

Here is the weird thing which has to be a stupid simple thing I am missing.
It works 100% as expected in StudioX.
However when I publish it and run it through UiPath assistant I see it adding in and appending so it is working. However when the automation is complete I look at the MasterFile and it didn’t save any of the changes.

What am I doing wrong?

Thanks,

@sprichett

In use excel file did you check the option save ?

Cheers

@Anil_G I have tried both. That is why I added the save at the bottom just in case it wasn’t working.

I have also tried using it as a template and not using as a template. It is almost as if it works but then something overwrites it to reset it back to original. Either way I do it I get the same result which is that it works in Studio X but not when I publish.

See screenshots below,

@sprichett

Template does not make a difference…try include save in both…and save file activity to be inside the loop…can you try the same please

Cheers

Hi @sprichett

Once try like this

@Anil_G Still the same result,

@lrtetala I’m trying to do this in StudioX if you have a suggestion for StudioX?

@sprichett

In StudioX

@sprichett

Have you tried this

@lrtetala I started a new task and recreated exactly what you have.

Same result it works 100% in studioX but not in UiPath Assistant.

Would this be an issues with my version since I have a community license???

Maybe this can shed some light on what is going on -

Ok so I do see the correct saved excel document however it is saving it in this location here

C:\Users\700979.nuget\packages\append2\1.0.3\content

No matter what I do with a Save Excel As activity or putting in the full path it continues to put the correct saved excel in that location instead.

What is going on here???

So I got it working by moving everything to the Desktop instead of the Project folder. Any idea why it would put in a relative folder path even when I put in the full path?

As soon as I moved it outside the project folder it is working fine in both StudioX and with the assistant,

Hi,

If you want to make changes to a particular excel file than you have to use full path for that file.

image