Excel always saving in wrong location


#1

Hi all,
I have a config file where it reads a file location(path).
I go to website ,
open the needed file
and try to save as in the location ( where it reads from the config file)
it shows that is typing right location( in type into activity ) but when the bot clicks save ,
it is always saving in C:\Users\pema.sherpa\AppData\Roaming\Microsoft\AddIns\download1.xls ( it saves in this file path if I try to save it was xlsx or xls file)
Help me !
Thank you


#2

Where are you typing the location?
If it is in the toolbar at the top, are you sending [k(enter)] after you type the path?


#3

I don’t think so.
here is the screen shot.
save%20error


#4

but here its not typing the path in the screen shot.
Give you path in the file name text box using type into activity.

if you are not giving any path it will store in the default path only.

Regards,
Arivu


#5

save_dwnld is a variable and inside that variable " I have passed the “path” string


#6

HI @Pema_Sherpa,

can you check once again weather bot is typing the path or not.


#7

yes it is typing is does show that it is typing, but after the typing is done, it saves it somewhere else with the same file name


#8

are you typing the full path.

you need to type the full path like
c:\user\download\filename.xlsx


#9

So the path is in that variable save_dwnld, right?
Did you check if the path is correct?
I just tried it and it worked fine: SaveFileToLocationTest.zip (155.9 KB)


#10

yes I am typing the full path but without the .xls or any other format.
thing is yesterday it was working fine but now it is not working, but the weird thing is that it is working for my other processes.


#11

C:\Users\pema.sherpa\Desktop\Yokohoma is my path and will add +“download1” as a file name
and then I select the right format for excel. which is when only “download1” remains in the type into box and the path is already changed.


#12

Try like this
"C:\Users\pema.sherpa\Desktop\Yokohoma\"+"download1"

Try to use download1.xlsx
"C:\Users\pema.sherpa\Desktop\Yokohoma\download1.xlsx"


#13


I just tried that again , this pops up


#14

Hi @Pema_Sherpa,

Dont change the Save as type Field keep as it as.

Try to pass the value in the file name field like below and try again.
"C:\Users\pema.sherpa\Desktop\Yokohoma\"+"download1.xlsx"

Regards,
Arivu


#15

sorry I take it back it saves the file not as an excel but as a web page… hmm. interesting…


#16

as soon as I change the save as , it goes to that file path. hmmm


#17

great, if you are facing any problem let you know @Pema_Sherpa. :wink:


#18

sorry I edited the post it is giving me error…


#19

Hello @Pema_Sherpa, may be you can try this:

  1. Uncheck the Simulate and Send Windows Message (if checked)

I happened to have the same problem (it seems like typing but always end up saved as the same file) and it worked well when Simulate or Send Windows Message is off.

  1. About the “Save as type” problem keeps showing, have you checked this?

#20

yes , I used the listed above, as a work around.
thanks.