Excecution wont stop automatically "terminated abruptly!"

studio

#1

Scenario:

Excecution wont stop automatically when robot is finished. I run my process with studio and output says that process is finished and icon has dissapered on task bar showing that robot is not doing process anymore but on studio it wont stop excecution automatically. You have to manually go an press stop button and it gives error exeption below.

Studio/Robot/Orchestrator Version:

Studio 2017.16435

OS Version:

Win 10

shows exception when pressing stop after robot is finished

Message: Job execution terminated abruptly!

Exception Type: Exception

System.Exception: Job execution terminated abruptly!


#2

The error is normal because the robot stopped before you hit the stop from Studio.

Please describe your scenario (use case) to guide you.


#3

But I dont understand why studio wont stop automatically like usually.
I run my process normally and the robot will finish it work and output says that execution ended.
But in studio the process is excecuting and all files are write protected and i need to now stop it manually with “stop” button and it shows the error.
Usually i stop it it just says it is canceled. How to get it automatically stop the excecution when robot is finished in studio?


#4

Do you start a robot from Orchestrator while Studio is open ? please describe with steps the scenario:

1…
2…


#5

Never mentioned orchestrator.

  1. I start process wit “Run” button in studio.
  2. Process excutes (workflow)
  3. Process finishes / robot stops executing
  4. Studio is stuck and wont stop exceution need to manually press “stop” button.

(I have restarted studio couple times and restarted computer and still it wont work)


#6

Can you describe the workflow ?


#7

Workflow:

  1. Opens the Browser
  2. Logins to the page
  3. Loads excel file (saves it)
  4. Closes the file and saves datatable
    (repeats steps 3 and 4)
  5. Closes browser
  6. Workflow finishes no errors

Does it affect that steps 3.4 are invoked from workflows. If it ends with invoked workflow it wont close properly?


#8

we will investigate and come with a solution


#9

can you give us the workflow ? maybe you can create a temporary test user for us, if necessary.
this scenario is often used without issues so i m suspecting something in the invokes or when saving the excel…


#10

Yeah it seems it is excel related. I did also workflow with two ecel application scopes with read range and after exceuting this it will get stuck as previously.

GetDatatables.xaml (10.3 KB)


#12

I tried your workflow and it runs OK from studio.
Can you provide some excel files? (I tested with my own xlsx files so maybe that makes a difference)

Adrian.


#13

We’ve experienced this issue with large files - at the end of the workflow it pauses. Also if you’ve got a high volume of log messages.

However, it’s happening now for me and neither of the above reasons apply. My flow reads in a json file (only ~30 lines), deserialises it into a json array and then for each item in the json adds it to a dictionary argument. I get the normal "execution ended in: " log message but the Run button is still greyed out and the Stop button is still active. Clicking on that yields the OP’s error message.


#14

Hi I am also using a heavy file and facing the same issue.
Studio shows in Output window: execution ended in: 00:00:43 but process still keeps running. and when I stop it manually it gives me following error:
Message: Job execution terminated abruptly!

Exception Type: Exception

System.Exception: Job execution terminated abruptly!

I have used excel workflows before as well but never faced this thing. The only difference here I could guess is the big file size.
Please let me know if anyone has the solution for this.


#15

Issue is resolved just by changing argument value to IN. Earlier it was IN/OUT for output datatable of excel.

I was reading a big excel and storing the result in argument of type Datatable with direction set to IN/Out now I just changed it to IN or you can just use variable instead of argument, that worked fine too.

Tried so many scenarios mentioned below but nothing worked out:
-Checked the workflow, isolated different set of blocks to pinpoint where the actual issue is happening

  • on analyzing the details, the issue is related to the input excel file with big size
  • input excel file contains 32k rows and 56 columns
  • tried reading the excel file using excel application scope (earlier it was a “Read CSV Activity”) could see the workflow the getting executed the robot process is getting consumed, but the process still continues in UiPath studio we need to stop it manually
  • tested with a small file (200 records) worked perfectly fine
  • tried by specifying a particular range in ReadRange Activity, sane error
  • used close application (excel), kill the process, terminate worklfow activity, still the same error
  • Checked the workflow and the memory utilization and the CPU utilization simultaneously while running the workflow
  • Tested reading the excel using Excel application in a separate workflow, able to read it successfully
  • Removed the parallel execution for reading the input excel files and changed into a sequential execution
  • Isolated the large input excel file, the workflow ran successfully.
  • While using the large input excel file the same exception encountered

Pass mail message as output argument
#16

I have noticed the same issue when trying to pass an argument from an ‘open’ activity output. Both open browser and open application have the same problem.

Any thing that comes out of the ‘output’ field cannot be passed out as an argument. I’ve tried assigning it as a variable and then as the arg to send out, doesn’t work. What the browser/app opens doesn’t seem to have any effect either and having the argument set as in/out also doesn’t work.

my workflow
Seq1 starts
Seq1 runs ‘launch workflow interactive’ to Seq2
Seq2 runs ‘open broweser’ with that output being an argument to send out
Seq2 tries to send out the output of the ‘open broweser’ as an arg
bot never ‘leaves’ Seq2 to go back to Seq1 after Seq2 finishes and hangs indefinitely

Running Seq2 by itself will have the same reported issue of running and ‘finishing’ but UiPath still thinks the bot is running.

I have also tested this with ‘invoke workflow’ which works perfectly as expected, so it only happens with ‘launch interactive’. I can proceed with my use case with the invoke method, just letting you know of other cases of the same issue.


#17

I am facing the same issue now with one of my workflows. On reviewing the different activities it is clear that one looping activity incorporating 2 workflows has the issue .The process goes this way

  1. Read the lines of notepad .
  2. Use looping for each of the line and split it based on a character (this is where the Bot doesn’t stop execution ) .
  3. Add the split string to the DT using add data row .
    Can some one help?

#18

Thanks. This helped.


#19

I am also facing this issue.
The studio version is: 2018.1.3

The workflow is quite simple:

  1. Go to Outlook mailbox
  2. Download the attachment to a certain folder

BTW, I’ve tested that if I change all the “OUT” arguments to “IN”, the problem is gone. (But they are not supposed to be “IN” arguments"
It has never happened to me before.

I’ve attached the workflow here, if someone can test it for me, that’ll be much appreciated!

The only thing you need to change is the outlook account in the “argument”.
RetrieveData.xaml (15.0 KB)

Thanks!


#20

Any solution to this, please let me know. @Gabriel_Tatu

version 2018.1.3,2018.1.4


#21

What is your exact issue?