Example of Automatic Recording with Basic and Desktop basic problem


#1

Hi,

I’m going through the Level 1 training materials for Lesson 4 Recording.

It suggests going through the UiPath documentation so that’s what I’m doing.

The very first part of this suggests a basic recording version of writing some text to notepad and then changing the font and then a desktop recording version of the same process.

When I try following the steps of the basic recording version I can’t get the font to change. Yes I select the different font but it is not activated in the font window (even if I double click rather than single click) don’t really see what I’m doing wrong here and the only version of the answer supplied is using the desktop recording version of the solution.

Here is my xaml in case anyone can see what I’m doing wrong (must be a simple error).

Main.xaml (9.2 KB)

Can’t get it to change in the desktop version also

Automatic Recording Desktop.xaml (13.9 KB)

Thanks,


#2

Hi @charliefik,

I think aaname creates the issue. Instead you can use the below selector.

<wnd app='notepad.exe' cls='Notepad' title='Untitled - Notepad' />
<wnd cls='Edit' />
<ctrl role='editable text' />

Hope it helps!
Thanks,
Saranya K R


#3

Hi @SaranyaKishore,

Thanks for the reply but the only selector I can see in the Main.xaml with the aaname element is in the Type Into activity which puts the text into notepad (is this the selector you were suggesting changing?) I thought this bit was working fine the problem is changing the font in the select item which although appears to select bold in the combo box list doesn’t seem to then put that value into the textbox and so the font is not changed.

I may well be not following your solution but I’m not sure for certain which selector you are suggesting to change.

In fact I can fix it by removing the select item activity and replacing it with a type into activity and putting bold into the Font style text box BUT I’m trying to follow the instructions and presumably select item activity should work so I’m trying to figure out why it isn’t.

Thanks,


#4

The selector has to be changed in the Type Into activity.
Regarding the select item activity, could you attach screenshot where you are clicking.


#5

Main.xaml (9.2 KB)

Above is the xaml for the workflow I am having problems with.

As I understand what you are saying. Here is the type into activity that you mentioned

image

Here is it’s selector

<wnd app='notepad.exe' cls='Notepad' title='Untitled - Notepad' />
<wnd aaname='Text Editor' cls='Edit' />
<ctrl name='Text Editor' role='editable text' />

You are saying that I need to change the selector to

If I do that I don’t see any change to the issue with the font not changing which is my problem (it seems to run exactly the same way as before).

I believe the problem is with the select item activity

image

which should be picking bold from the combo list in notepad’s font dialog box

image

When I run it. It does pick Bold in the list but then doesn’t put it into the Font style textbox (which is showing as ‘Regular’ in the screenshot above) which is my problem.


#6

It does work fine for me, the only error I get is aaname.


#7

ok so if you start with the font not bold in your notepad font settings at the end of the process it has been changed to bold right?


#8

Yes, it changes


#9

ok might try a restart then as that doesn’t seem to make sense why it wouldn’t also work for me thanks for helping out


#10

Okay, try re-recording the scenario.


#11

Will do


#12

New recording now should change font to italic

StupidNotChangingFontExample.xaml (9.3 KB)

Still doesn’t change font. ARRRRRGGGGGHHH!!


#13

New recording does not work for me. I changed a bit in the selectors and now it works.

For Type Into,
<wnd app='notepad.exe' cls='Notepad' title='Untitled - Notepad' />
<wnd cls='Edit' />
<ctrl role='editable text' />

For Select item,
<wnd app='notepad.exe' cls='#32770' title='Font' />
<wnd ctrlid='1137' />
<wnd ctrlid='1000' />
<ctrl name='Font style:' role='list' />
<ctrl name='Bold' role='list item' />

Try changing this.


#14

Thanks for your input @SaranyaKishore

My currenct Type into seems to work for me and is

<wnd app='notepad.exe' cls='Notepad' title='Untitled - Notepad' />
<wnd aaname='Text Editor' cls='Edit' />
<ctrl name='Text Editor' role='editable text' />

but I’m changing it to

<wnd app='notepad.exe' cls='Notepad' title='Untitled - Notepad' />
<wnd cls='Edit' />
<ctrl role='editable text' />

(tried that change on it’s own makes no difference to my results so far)

Now changing my select item from

<wnd app='notepad.exe' cls='#32770' title='Font' />
<wnd ctrlid='1137' />
<wnd ctrlid='1000' />
<ctrl name='Font style:' role='list' />
<ctrl name='Italic' role='list item' />

to your selector which is (the only difference I can see here is that you have bold instead of italic so I’m going to change my notepad current setting to regular to see if the change of font works also have to change the ‘item’ value to “Bold” in the properties window)

For me exactly the same thing happens you see bold being selected in the list but not being passed to the Font style text box (part of the combo box) and therefore not changing the font in notepad.

What I have noticed however by putting a break point into the workflow at the ‘select into’ (and running in debug mode) is that if I hit ‘step into’ when it stops at the select item it first selects ‘bold’ in the index list and still stays on the select item activity, if i then press step into again it then closes the font dialog box and moves to the ‘click button’ which should be clicking the OK button on the font dialog (which has at this point disappeared). This may be a bit of a red herring though as the main issue is that although bold (in this case, because of the selector change) has been selected in the drop down list it still wasn’t activated in the Font Style ‘text box’. before the font dialog box was closed.

As it looked like the click button activity was superfluous (when stepping through) I commented it out and reran it normally. In this case the font dialog didn’t disappear so the click button was required. (don’t understand why there seems to be a difference in the way the activities work in debug rather than debug mode anyway back to my original issue, Font is still not changing!

Thanks for your time though guys all the best


#15

The workflow is fine.
Instead of debug mode, run it normally. It may work.


#16

I only ran it in debug mode because normal runs weren’t working (I’ve run it loads of times in normal mode). I don’t think there’s any point wasting any more time on this if it seems to be working for you guys but just not for me (hopefully its machine specific) and I have a work around anyway of type into the ‘text box’ instead of selecting from the drop down.

Thanks for your help guys


#17

Okay sure, all the best !


#18

Hi @charliefik did you get any resolution of your original problem, I am trying to practice Lesson 4 d
decoumentation Recording example facing the exact same problem.When I type in it gets changed but not when i am selecting the font.


#19

Sorry @noopur.dwivedi,

I decided to move on. Typing directly into the text box works so I went with that. However I’m sure that there are examples where you should want to and be able to use the drop down values (that’s the whole point of the drop down after all).

Please, if you do find a solution could you pop it onto this discussion. I really would like to know the answer I just couldn’t spend any more time on it.

I will post too if I uncover the solution.

All the best, good luck!


#20

Yes I took suggestions from you on the same and typing worked, I was really stuck on this drop down thing for couple of days.Would surely update you if I figure out the resolution.