Notepad - UiPath fails to change font on very simple example

studio

#1

Scenario: Doing lesson 4 on UiPath academy, trying to vhange font in notepad. Windows 10 pc.

Steps to reproduce: Bsic or desktop recording. Exactly as in video (start recording, type into notepad, open menu format, then font, choose a font, click ok button.

Current Behavior: font name changes in the combobox but clicking Ok does not change the font although it closes the dialog (very strange). When I reopn the font dialog, the original font is still set (didn’t change) Changing font style or size works fine. Also note that even during recording, the font doesnt change!

Expected Behavior: font changes.

Studio/Robot/Orchestrator Version:Studio 2017.1.6414

Last stable behavior:
Last stable version:
OS Version:Windows 10
Others if Relevant: (workflow, logs, .net version, service pack, etc):


#2

Hi,

Make sure default font style of the notepad is different than that of one in the workflow.
When you run the workflow for the second time it doesn’t change font because font style of notepad and in your workflow are same.

NotepadAutomation.xaml (10.1 KB)


#3

Thanks for the quick reply, but it’s not so simple. Also I mentioned that even during recording, the font change doesn’t take any effect after clicking the ok button.


#4

workflow not running properly ?


#5

I don’t understand your question… the workflow isn’t running properly because of the reasons I described, but the workflow doesn’t produce an error or anything. The problem also occurs during Recording. I think UiPath isn’t setting the Font Name properly in the dropdown of Notepad or something.


#6

Workflow works fine for me .:roll_eyes:It’s a simple workflow not sure why your unable to do it .@andrzej.kniola any words ?


#7

For anyone with the same, it was dual monitors. Even with “Duplicate” on, it just isn’t working. Could be my port replicator, dunno. So if I choose PC only, it works.


#8

Hi, I am facing the same issue here. What do you mean by “Duplicate” on ? How did you make it working ?


#9

“Duplicate Screen” being where the screen image is the same on both monitors…that didn’t even work. Going to “PC Screen Only” resolved my issue. This is Windows 10. hope that helps


#10

Hi, I’m experiencing the same problem. I don’t have a duplicate screen as it’s a laptop. There is only one choice in my screen selection 1. Mobile PC Display.

I’m using Windows 7 professional.


#11

Its happening to me tooo. The Lesson4 Practice 1 .Workflow runs smoothly selects the correct font Style and Size . But after presssing OK the font doesnt change. The workflow finishes without any errors. But the font is not changed


#12

i am also facing the same issue


#13

I’m also facing the same issue. The current display option is pc screen only. Anyone here any solution apart from changing the display option.

OS: Windows 10 pro, [Version 10.0.16299.125]
uipath version: 2018.1


#14

Hi There,
Could you help to solve this problem, please?
Whatever i have done, doesnt help me to change the font.
It doesnt change the font at first nor second run …
thank you


#15

The problem is related to the list selection, it seems that the robot changes the list but notepad doesn’t detect it. The solution is to type the font instead of selecting it from the list.
image

Working workflow attached.NotepadFontChange.xaml (9.8 KB)


#16

This solution works, Thank you.


#17

This suggestion worked for me when i tried the Basic recording, however when I was creating a Desktop recording, it did not capture the “type into” activity where you specify the font, so I copied the “type into” activity from the basic workflow and copied it in the desktop workflow. This worked for me. This may not be an elegant solution, however you can try this approach when you need a quick fix. I am a beginner, I think there are more elegant solutions


#18

Hi There

I ran into this issue, I got this working by adding a click item to beneath select font.

image

Hope this helps!

Regards
KG


#19

Thank you !!! It works !! Even with dual monitors if that matters.