Basic Recording is different than tutorial

I try to make this example for user interface recording.
User Interface Recording

When I tried basic recording I am receiving a message saying “Do you want to use the Anchor?”. I selected “no” and completed the recording. After that the result was different than tutorial. In the tutorial font option is changeable. (You can see here)

In my result, the font option was not changeable.

I solved this issue with clicking font-style textbox. I send font-style as a parameter to textbox. Then click OK Button. But both of basic and desktop recording listbox can not be detected.

P.S. UiPath 2019.4.2 Community Edition

@bk52

Instead of Click activity use Select Item activity and indicate that fonts drop down box. Then you can change it to any font which ever you want to use.

I also noticed this. In the recording, the recorder automatically chose the correct object to use: Select Item. However, in practice, as the OP said, the recorded output is different in that it picks the Click Item.

I also was thrown by the “do you want to use an anchor” dialog box.

This inconsistent behaviour between the tech and the up-to-date tutorials is frustrating.