Error when capturing in Chrome

image

I am getting the above error when i am trying to capture the elements in chrome browser.

UiPath Version - 2019.4.3
Chrome Extension - UiPath Web Automation 9.0.6821
Chrome Version - Version 69.0.3497.92

used to work earlier and now it does not work. I have tried all the workarounds that people have been posted but unfortunately it is not working. I am using server which does not have internet access.

Can someone help me to get this sort since i have tried so hard but no look.

Thanks

1- Open Chrome Extensions (chrome://extensions/) and check the UiPath extension is enabled or not.
- if it is enabled - please disable and enable
- close all chrome browsers (all users connected to the machine)

2 Likes

I did and yet the issues persist. I have done this many times and could not find out what the issue is and this used to work fine earlier

Hi
Did we try with other browsers like IE which doesn’t need any extension to be installed
cheers @Mahesh5502

2 Likes

cannot do that since the solution was once developed using chrome and was working fine. it needs to be used again since some testing needs to be done. so it is only chrome and i am wondering why it is not working now since it was working fine by the time when i was doing the development and using it.

2 Likes

Did we try Reinstalling the extension
And hope you would have referred this as well

Cheers @Mahesh5502

1 Like

yeah @Palaniyappan this was done many times but the issue still remains. It says that the NativeMessagingHost cannot be started. I have pointed the resgistry editor to the relevant .crx file also for the user as well as the machine.

Reinstall the chrome and then install extension Ince and try pls
@Mahesh5502

1 Like

i have done that also. I had the Version 69.0.3497.92 (Official Build) (64-bit) installed and i upgraded it to the Version 77.0.3865.120 (Official Build) (64-bit). would it work if i update the extension? does it have anything to do with the chrome version?

Hmm. Fine
Kindly check once whether there is firewall blocking or any whitelist or any issue with antivirus

Cheers @Mahesh5502

1 Like

Please, check if you are not running your browser in private mode. If yes, make sure that the UiPath extension is allowed to be used in that mode.

1 Like

Hi @Damien, I have already enabled it even though it is not running on Private Mode.

1 Like

Unchecked runtime.lastError: Failed to start native messaging host.

Error in event handler: Error: Attempting to use a disconnected port object
at Object.CallFunction (chrome-extension://dkgencfabioofgdmhhjljpkbbchbikbh/Loader.js:244:29)
at RegisterWindowId (chrome-extension://dkgencfabioofgdmhhjljpkbbchbikbh/Loader.js:565:25)
at chrome-extension://dkgencfabioofgdmhhjljpkbbchbikbh/Loader.js:552:13

this is the error message that i get in tracers. it is to do with the NativeMessagingHost
when i check the TaskManager i cannot see the NativeMessagingHost is running

Is it a enterprise or community edition
@Mahesh5502

this is enterprise edition

Fine
Kindly raise a ticket to technical team on this
Pls

Cheers @Mahesh5502

@Palaniyappan do you think they will be able to help since this is not related to Studio, Orechestrator or BOT?

1 Like

@Mahesh5502

It might be because of your company policies ! Check if they let you install new extensions…

You might have something like this :point_down:

Sans titre

Check on an other browser to see if you can install it.

1 Like

Yah they would surely help us on this
@Mahesh5502

1 Like

@mz3bel - you are right i have this and it says that the browser is managed by the organization, but this worked earlier with the same configuration earlier and i have another machine with the same configuration and it works on that too. Even though it does not allow to download chrome the extension comes in the platform installer.