Error send hot key

hi, I have the following problem
when sending the hotkey, give me this error “write text failed”!!
anyone can help
thks in advanced

write text failed



Can you upload a screenshot of your send hotkey activity?

That’s bizarre, it works for me.

If you’re trying to close a tab/window, there are activities for that.

Alternatively, you could use “[d(ctrl)]w[u(ctrl)][k(enter)]” in the “Type into” activity to see if that works?

1 Like


This is a known issue for the Send hotkey activity(will be fixed in next releases). I could reproduce on my CE 2017.1.6522. The workaround is the one above, at least it works for me.

@Short what version do you have? Could you please try with the example below?
ctrl-bug.xaml (10.6 KB)


The first try came up with the error, then I realised CTRL was still on (clicking on the different parts of the flow selected it as well as any other parts I clicked). I unticked the SpecialKey option and it worked fine.

I have version 2016.2.6232, apparently it hasn’t been updated in a while :confused:


Thanks for your feedback, I will pass this to QA team to do some digging. :slight_smile:

I had the same issue :frowning:

I had the same issue like earlier hotkeys was working fine but at once it is not responding.

Seems good workaround!!
For example, you can alternately perform ctrl+alt+f5 like this:
TypeInto “[d(ctrl)][d(alt)][(k(f5)][u(alt)][u(ctrl)]”

Hello, I am trying to use the user event ie Monitor keyboard and got the following error
Also, can the user events trigger work on VMs running in unattended mode

What studio version are you running? Can you send me the workflow?

Hi there. I’m currently having the same issue. I need to send a key combination “ctrl+shift+v” into a cell in Excel. Its giving me error messages when I use the Send Hotkey. For me the macro isn’t working either. Please help.


did you know the solution for this ?

It seems to be still an issue.
When will it be solved?

If the application window is in focus then just check the “Special Key” option.
Just don’t do an “Indicate on Screen” and leave the selector field blank.
I faced similar problems while trying to pass an “ALT+DOWN” key in Excel to expand the Filter on a column.

Hi @Short/@sumitctm ,

Can you tell me what would be the alternative keys for Alt+F4

I’m using 2018.4.4 version and all of a sudden, send Hotkey is not working. My process is running on VM