Error message Object reference not set to an instance

Hi! I got this error message. Invoke System1Login workflow: Object reference not set to an instance of an object.
Does anyone know how to solve this?

Hi @Sine,

It means that there is an argument from System1Login workflow that is not receiving the values. “Object reference not set to an instance of an object” means missing values in an argument or variable assignments.

Regards,
PD

Thank you very much for your quick answer :slight_smile:

I thought it should look like this in the System1Login workflow?

Summary

Hi @Sine,

Consider arguments as your gateway to pass values in and Out; So you don’t assign them default values unless you are just testing the workflow. If you have the URL value assigned inside the System1Login workflow, it means you are giving it a default value.

For this exercise we will pass the acme URL as an argument value coming from outside the System1Login workflow. Therefore, remove the URL value from the arguments section and please place it where you have the Invoke System1Login workflow --> Import Arguments --> System1URL Value = “https://acme-test.uipath.com

Hope this helps!

I did the changes - so I have inserted the URL in the Import arguments where I have invoked SystemLogin workflow.
Now I am trying to test the System1Login workflow but I get this message…: Open Browser: Value does not fall within the expected range.

Hold on I just noticed that your screenshot has System1URL Argument Type as browser and not string.

Open Browser URL property accepts a string value. Please update the type and you should be good.

Gret! It worked for a while but when I run it from Init in order to get all the credentials, I get this error message [Invoke GetAppCredentials workflow: Can not convert Object to String.] when I enter System1Login workflow…any idea of how I can solve this problem? :slight_smile:

Hi PD2, I have another question. I am working in the get transaction data workflow and in the assign stage within “if more items”, I get this error: Compiler errors encountered processing expression “in_WList(in_TransactionItem)”. Option Strict on disallows implicit conversions from String to Integer.
I have tried almost everything but I cant figure out how to solve tis…hope you can help :slight_smile:

Hi @Sine

you should use in_TransactionNumber there and TransactionNumber is of type INT

image

Thanks,
Prankur

Hi Prankurjoshi :slight_smile:
Thank you for your help!
When I try to run Get Transaction Data workflow I get this error in the very beginning “Get Transaction Item: Object reference not set to an instance of an object.” What does this error mean?

1 Like

Please make sure that your in argument in_WIList has some value.

Use a message box or write line activity and try to print the count of in_WiLIst value in Main.xaml and in GetTransactionData.xaml

Thanks,
Prankur

I think it is because I have not linked the data from out_WList (The Extract work item data table workflow) to in_WList (GetTransaction data workflow). How do I do this?

right now my System1Extract work item data table looks like this

Assign value on this out_WIList to a local variable let’s say WIList in main.xaml

Now when you Invoke GetTransactiondata.xaml assign in_WIList = WIList

1 Like

So I need to create one more assign activity in System1ExtractWork item data table workflow?
Because then I need to create an argument for WList, because it does not seem to appear, because WList is only a variable in Main

@PrankurJoshi

Can you please check that you have some value in WIList?

Try to print

in_WIList.Count.ToString

In GetTransactionData.xaml

Thanks,
Prankur

Where should I put value? these are my arguments - are they correct?