Assignment 3 - Practice 1: Invoke InitAllApplications Workflow Error: Object reference not set to an instance of an object


#1

Hi there,

I get the following error when executing, and I do not know where it is coming from:


System error at initialization: Object reference not set to an instance of an object. at Source: Anonymously Hosted DynamicMethods Assembly

When I execute with skipping the workflow that extracts the data, it does work. Does anybody have any idea on how to fix this?


#2

New System.Data.DataTable” give this value to default value in variable declaration of dt_WI. IT may solve your problem.


#3

You may not have given the proper values to the arguments of the invoked workflows.
Click on import argument of the invoke workflow activities and make sure the arguments have proper values, especially the ones that require details from the config file!


#4

Thanks, it works now!

I’ve ran into a new problem with the NavigateToWIDetails workflow, as it does not navigate to the Work Item. It constantly opens up new windows and tries to navigate again.
I think it has something to do with the arguments I’m using.



#5

Have to tried to validate the in_ACME_URL by printing it? there might be an issue with arguments what you are passing


#6

Thanks for the suggestion.

Through debugging I found out that “in_ACME_URL” was not the right argument name, as defined in the dictionary. The right one is “in_WIID_URL”.