Error: Desktop has been disconnected while performing UI actions


#1

Dear all,

I have published my project on a Virtual Machine with only UiPath Robot installed.
The PC has several users and the users log in with remote desktop and use a same application at same time.
The users access the Virtual Machinewith remote desktop.
When I start the Robot from the Robot tray, let it run and, close the remote desktop and reopen it again I can see that the robot has stopped running with the following error message:
“Desktop has been disconnected while performing UI actions.”
How can I ivercome this problem?
is there some need to add some parameter in local computer registry?
Thank you so much for your help friends,
regards,
Camilla :slight_smile:


#2

Have you tried ‘Launch Workflow Interactive’ activity to invoke your workflows instead of ‘Invoke workflow file’. I believe this basically works even when the vm is minimized or closed.

We had a similar issue where when VM is minimized or closed, Elements were not being identified by the workflow and got it resolved by simulating all the activities and replacing Invoke Workflow file to Launch Workflow Interactive.

Hope it works for you as well.

Thanks,
Rammohan B.


#3

Hello @Rammohan91.
Thank you so much for your precious response.
I haven’t already tried to use the “Launch Interactive Workflow” to invoke my workflows.
I’ll try and let you know if it works for my case.
Thank you so much again,
Camilla. :slight_smile::relaxed: