Error 407 Proxy Authentication Required on UiPath Robot

Hi

In an attempt to edit the robot key and orchestrator URL, this error pops up

There were no issues on configuring the robot previously. Any ideas?

Capture

1 Like

Hi,

Can you please provide Robot and Orchestrator versions? Did you try to restart the Robot service?

Hi Ovi

Orchestrator version: Orchestrator Community 2017.1.6547

I take it that the UiRobot version is the same as the studio I am using.
2016.2.6274

I have tried restarting the Robot service, the same error persists.

Best

Try changing the defultproxy setting in the uirobot.exe.config file as follows:

<system.net>
    <defaultProxy useDefaultCredentials="true" >
    </defaultProxy>
</system.net>

It seemed to resolve the issue in our environment.

Cheers

David

3 Likes

i tried to add this to my config file but after that the robot service did not start

Hi r u able to solve dis issue?

@flyingriefdy, I have the same error. How did you solve?

Hi @Fer

See our official documentation here:

Hi,
I had the same problem.
Unfortunately UI Path is not ready to work with proxy authentication providing an User Name and Password, exactly as you do when you creat an HTTP Web Request using proxy for example.
Even following step by step provide in UI Path resources it doesn’t work.
In order to fix that problem you need to establish a VPN or include https://platform.uipath.com in your firewall rule in order to do not require proxy authentication for this url and make this site visible inside your network.

Hope I could help you with.

Rgds,
~Diego Turati

1 Like

Hi @DiegoTurati,

Just curious, does this affect NuGet packages too? I’ve been trying to install packages from NuGet, behind a proxy with authentication, and seems like it is not working. I’ve done the configuration here:

But it’s failing too. Would you happen to have any advice? Thanks a lot for your time.

1 Like

Hi @Nisa,

Yes , it affects too. In my case i tried everything but just after including a firewall rule I was able to connect. Looking for some alternative here in the community II found something the user mentioned it worked to him, I tried from my side in the past but with no success.

If you want to try , follow the post below:

~Diego Turati

1 Like

Hi @DiegoTurati,

Yea I saw that too! I previously tried the link that you sent before, and it didn’t work the first time. Surprisingly, I just tried on another PC and could get the nuget packages. There must be some settings that I’m unaware of - will try and figure it out and update you if there’s anything interesting that I find. Still haven’t gotten around the Orchestrator problem though :joy:

To clarify - I tried updating the nuget.config manually (typing proxy with username and password) and it didn’t work. It only started working WITH the command on nuget.exe, and the same copied to the UiPath folder. Just thought of letting you know, and thanks a lot for your help!

1 Like

Hey @Nisa! woww Great news!!!
Good to know you was able to solve it! If you can, mark this topic as solved to help other members to check the solution!

Thanks a lot for your position about that!

~Diego Turati

1 Like

Hello!

I have a similar question. The orchestrator and sql server on our dev environment is on a different domain than my uipath studio. We typically use a vpn access when connecting on the Orchestrator domain. Will I need to configure anything so my studio can communicate with the Orchestrator?

Thanks in advance

1 Like