Error 407 Proxy Authentication Required on UiPath Robot


In an attempt to edit the robot key and orchestrator URL, this error pops up

There were no issues on configuring the robot previously. Any ideas?


1 Like


Can you please provide Robot and Orchestrator versions? Did you try to restart the Robot service?

Hi Ovi

Orchestrator version: Orchestrator Community 2017.1.6547

I take it that the UiRobot version is the same as the studio I am using.

I have tried restarting the Robot service, the same error persists.


Try changing the defultproxy setting in the uirobot.exe.config file as follows:

    <defaultProxy useDefaultCredentials="true" >

It seemed to resolve the issue in our environment.




i tried to add this to my config file but after that the robot service did not start

Hi r u able to solve dis issue?

@flyingriefdy, I have the same error. How did you solve?

Hi @Fer

See our official documentation here:

I had the same problem.
Unfortunately UI Path is not ready to work with proxy authentication providing an User Name and Password, exactly as you do when you creat an HTTP Web Request using proxy for example.
Even following step by step provide in UI Path resources it doesn’t work.
In order to fix that problem you need to establish a VPN or include in your firewall rule in order to do not require proxy authentication for this url and make this site visible inside your network.

Hope I could help you with.

~Diego Turati

1 Like

Hi @DiegoTurati,

Just curious, does this affect NuGet packages too? I’ve been trying to install packages from NuGet, behind a proxy with authentication, and seems like it is not working. I’ve done the configuration here:

But it’s failing too. Would you happen to have any advice? Thanks a lot for your time.

1 Like

Hi @Nisa,

Yes , it affects too. In my case i tried everything but just after including a firewall rule I was able to connect. Looking for some alternative here in the community II found something the user mentioned it worked to him, I tried from my side in the past but with no success.

If you want to try , follow the post below:

~Diego Turati

1 Like

Hi @DiegoTurati,

Yea I saw that too! I previously tried the link that you sent before, and it didn’t work the first time. Surprisingly, I just tried on another PC and could get the nuget packages. There must be some settings that I’m unaware of - will try and figure it out and update you if there’s anything interesting that I find. Still haven’t gotten around the Orchestrator problem though :joy:

To clarify - I tried updating the nuget.config manually (typing proxy with username and password) and it didn’t work. It only started working WITH the command on nuget.exe, and the same copied to the UiPath folder. Just thought of letting you know, and thanks a lot for your help!

1 Like

Hey @Nisa! woww Great news!!!
Good to know you was able to solve it! If you can, mark this topic as solved to help other members to check the solution!

Thanks a lot for your position about that!

~Diego Turati

1 Like


I have a similar question. The orchestrator and sql server on our dev environment is on a different domain than my uipath studio. We typically use a vpn access when connecting on the Orchestrator domain. Will I need to configure anything so my studio can communicate with the Orchestrator?

Thanks in advance

1 Like

Since the config-file-structure changed a bit for 20.4+ I could not follow you instructions a 100% but found a way to solve if for us using 20.4.4
I followed the steps described here: Redirecting Robots through a Proxy Server (

But additionally add the useDefaultCredentials-attribute.
The file looked something like this

<defaultProxy useDefaultCredentials="true" > 

I hope this helps someone else.



Hi @RPraschma

Thanks, your previous answer helps me a lot!

But bad news. As of v2021.4.0 this config-file-structure was removed. We are encountering the same “Proxy Authentication Required” again, it is a serious hassle to connect the Studio (in User Mode) to import/upgrade the libraries.

Would anyone happened to solve this new situation as well :flushed: ?

Hello same problem here with 2021.4.3 and 2021.4.4.

Hi @fahuet

Could you please have a look at this updated documentation article?


thank you for your answer.

I’ve updated uipath.conf with properly https:// … .pac file and also added a system environment variable.
The problem is : when the machine reboots/cold bood, uipath service still cannot contact Always the same error.

Kind regards,

At this point, I would suggest contact with our technical support to have a look. Maybe there is something that is still missing from the documentation that we have to add, but our support should be able to help here nonetheless: