SAP v750 not detecting Gui Elements even after scripting enable


I am developing a POC for project having SAP version 750 with Gui scripting enabled from Both client and server end.

The problem is that the UI elements are not being detected even on UI Explorer.

I tried the following:

  • Run studio and sap as administrator
  • Tried on the enterprise trial

Has anyone come across such as issue an been able to resolve it??

appreciate your assistance.


Run studio as administrator and then try once.

Hi Lakshman,

I tried that as well but it was the same. did that on SAP Too.


Could you please remove that connection from SAP and then reconfigure it new one. And then enable script on client side and restart SAP and check it.


Did that just now result is the same.

THen in addition i deleted the full cache from Local App data / Appdata / Documents.

Rerun studio as admin and checked the result is the same.


Then try with Computer Vision activities.


Computer Vision works but i am keeping that as a last option. Seems like from version 740 above this issue is there.

i will try downgrading the SAP Version and check again.


Yes may be issue with SAP v750. I worked with 740 version and it’s working fine. Don’t know about with 750 version.

Hi @lakshman,

Found the Solution. It works well with 750 (patch 4 & above) and 760 Patch 1… Assuming that the gui Scripting was enabled on the RZ11.

Try to keep the patches to the latest version possible. 760 tends to work a bit better.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.