Element Exists activity is not working

Hey there,

As you can see in my pictures, Element Exists activity is not working, in UiPath 2019 5.0…
The selector is right, it can find the element… but, it always returns false. Is that a bug? Or what I’m doing wrong?

I thought I could put a delay before the activity, but it doesn’t work also.

1 Like

Is the title value is Erro or something else??
If title changes every time then change the title value to ‘Erro*’
So it matches with all the titles starting with Erro…

Please consider the least attribute that matches the selector and omit the unwanted attributes like cls , ctrlid etc., (just for example).

Karthik Byggari


@KarthikByggari, yes, the title value is always “Erro”. And as you can see, the validate button in Element Exists is always green! So, that should mean it found the element… but, the output variable is false!
I tried to put a delay before, but it’s still not working. That’s why I think this must be a bug.

Hi @Aqua1986

Can you please create a sample workflow and check for simple element if exists or not.
I don’t think there is a bug reported to this activity.

Last thought: Is the element visible (window) visible when you are running the workflow.

Karthik Byggari

Hi @KarthikByggari,

That’s the reason it’s not working… It seems it takes time (one second?) to the element be active in SAP. So, when Uipath is running the workflow, it passes…

Pedro Pais

Ok, I notice it works if I have a breakpoint in the Element Exists activity, but if I don’t have the breakpoint, it doesn’t work, even if I have a delay activity before with 10 seconds…
(but the window - element - appears in the screen in 1 or less seconds)…

I didn’t say it before, but it is in a finally block, of a try catch… is it relevant?

Ideally it has to work.
It doesn’t matter where the activities are. I mean it can be anywhere in try/catch/finally block.

Before delay activity, bring the window to front and then add delay for 5 seconds and check.

I am using a loop to traverse a list of URL (for each row) and navigating to each URL to find a UI element (button), but the workflow is resulting in the UI element not found for 1st URL whereas it is there. However the subsequent passes the result is correct be it present or not. i tried it for sample 5 URLs.
Not sure why it is not giving the correct outcome for the first URL

I am having a similar problem, but with a JavaScript modal in IE. I’m in IE because modal’s aren’t supported in Firefox.

@Aqua1986 Did you solve this issue? I run into the same problem in SAP, for the first 10 Elements my Element Exists Actitivity workes fine. Suddenly it’s stops to recognize the elements and delivers “False”, even if there are more elements available.

I didn’t solved the problem finally but i implemented a retry activity which checks 3 times if the element exists. In some cases it helped me out, but i only helpes in about 80% of the cases, in all other cases the element exists returns false even the element is available on the SAP GUI.