Element Exist always shows false

The Element Exists Activity always shows False even if the element is available and the Selector can highlight the existing element. Any suggestions?

Can u elaborate ur scenario @jeyaprakasamm

In order for us to guide you, please share your “Element Exists” activity’s properties and its selector and also its selector’s targer in detail.

Change the properties of Element Exists.
WaitForready state to interactive or complete
Also try to get more unique selectors through ui explorer.


This is one of the item which is available actually but the Element exists failing

and this is the element

Try to increase your timeout and see. Sometimes, the element wait for few secs and set the result. Increase your timeout > 7500 ms and check if its happening again.

Dialog boxes are sometimes a bit tricky to be dealt with. You have to try multiple options to finally be able to perform your desired action. One of the final solutions can be CV Element Exists. With Computer Vision activities, you have better chances. But, in order to start, you can indicate an anchor and you can try to capture the OK button as your target instead of the whole dialog. Also, see if you can use an anchor on the text.

1 Like

Hi Atoi,

What is the CV Element Exists. How can I add that activity.

Last resort choice though.

No way. I have tried several combinations of selectors which UI Eplorer always highlights as correct - Valid in my “Element Exists” activity to find the element. However, every time I debug the project, the boolean result of this “Element Exists” activity is “false”, and so it is impossible to me to clic on it.

How is this possible? A Valid selector selection, which also highligts the correct element with the external red rectangle, but when it comes to reality, fails…

Any suggestion? Thank you very much in advance.

I will try now with the CV Element Exists, however, if I use it, how will I clic on the element afterwards?

Hello @ccrespo9669

In the modern activities you will be able to find activity “Check App state”. Can you try with that.

Thank you very much Rahul. I will try.

1 Like

At the end, I solved the problem. What I did was to “get Element” of the button I wanted to click on. Then I used this definition of the button inside the Clic activity and, it worked!!!

Thank you very much all of you who helped me!!!

Sorry, not “get element” but “search element”…

Hi Team,

Can anyone help on i am trying to upload excel zip file by clicking on ‘Choos button’ as per below screenshot and have tried Element exist, can anyone tell how to run this step with steps in that step?

I have tried Click option under Window Attach in Retry Scope activity.