Element changes after hovering

I’m automating a workflow in a web-based application.

There’s a button I need to press to show a dropdown, but this button only becomes visible if you hover over the area.
The problem is that I cannot generate a selector for this button.

Situation 1: the button before I hover over it, the button shows as >

Situation 2: The button when I hover the mouse over it, the button shows as

I have made a step to Hover over the area with the selector while it is showing as >, when I run the workflow this step goes well.

But when it comes to clicking, I cannot get it to work.
When I use the UiPath Explorer, the delay (F2) function doens’t work, if I left-click and hold the button remains as , but the selector isn’t created. As soon as I let go or click again to create the selector, the button changes back to > and I get the wrong selector.

Any idea? I tried the steps here: How to capture a menu element that appears from mouse hovering? - #9 by Palaniyappan (using the F2 delay, holding the mouse, releasing after countdown ends, releasing before countdown ends etc.) but it doesn’t seem to work for me. As soon as I click to create the selector, the turn back to >


Hi @dyvo, welcome to UiPath community!

Can you please check if any shortcuts or tabs work there?

Hi, do you mean pressing Tab until I reach the button? Unfortunately it doesn’t react to that. There is no hotkey associated with it either

I had a similar issue and used basic register. It worked.

Ok, i’ll give it a try. It wants to create an anchor based on the selector of >, is that what you experienced in your situation?

Hello @dyvo , Welcome to UiPath Community
Try this, Before indicating the Element, Just do right-click manually on the browser or some other place, and indicate the specific selectors. It may works.

Yes i continiued with anchor based. But my selector was different from >. I had the same problem in a drop-down list on a website.

When I’m recording the flow a selector box appears around the >, and it doesn’t change to the , so I anchored it to it’s initial state.

However when I run the flow, if I leave the hover step in, it can’t find the anchor point anymore. If I remove the hover step it claims to run the recorded steps, but throws an error on the dropdown selection menu (but I don’t see it opening the dropdown).

Hi, thanks for responding. I’m not sure what you mean? If I right-click it shows the back/forward/save as…/ etc menu, but doesn’t change the behaviour of the selector

If you right-click some other place, it locks the page selector and even if we hover over the button it doesn’t respond. At the time we can indicate the required selector.

Refer to this image, Hover over the Import setting without right click and with a right click

Use the “hoverable” mode by pressing F6

Where do I press F6? In the UI Explorer it doesn’t seem to do anything except focus on the Adress Bar of the browser.

Apologies if I missed this in previous comments but have you tried the hover activity too?

If you are struggling to get your cursor over the element when its not visible, try ‘clicking’ on another element nearby then using the click offset function in the properties to offset where the curser clicks, and align it with where the element should be

You don’t do it in Ui Explorer. You see it when you click “Indicate” for the activity. You need to be on modern, btw.

Hi Dillan,
The workflow I am using is:
Hover (to activate the button) → Click (to open submenu) → Click submenu item

Then use the hover activity, then the click activity, then the click activity.

To get the selector for the click activities, you use the hover (F6) function in the selector editor that opens when you click indicate element on an activity.

Ah, I’m on the ‘old’ style, can’t get used to modern. But I seem to have made it work with someone else’s suggestion, thanks though!

This actually worked, can’t believe how many hours I wasted on this. Thank you!

1 Like