How to Click on a button which is visible only on Mouse Hover

Hi All,

I am trying to click on below button which appears only on Mouse Hover. in UIpath, if I do Indicate on screen this button does not appear & I am not able to find the element.

Untitled

I have tried below method which is working but again it depends on the screen resolution and is not stable.
Find element “Memory” & then invoke Click activity by specifying the Cursor position OffsetX = 135.

Can anyone please let me know if there is any other method to do these activities.

Thanks,
Nilam

@nilam.dnaik Have you tried Clicking F2 to add a Delay and then Keep pressed the Button which you want , then When the timeout lapses Release the Mouse Press. But Before this be sure to add a Mouse Hover, so that it is Able to Detect the Button.

Yes I have tried pressing F2, & then clicking but the issue is button is not getting captured & it shows blank as below.

This is when Indicate on Screen is on even after Mouse Hover
Untitled

This is what getting saved after a click

Untitled

@nilam.dnaik During the 3 Second Delay when you have pressed F2, I guess you can direct to the button and Hold and Press the button which you want. Do not release the press. Not after the 3 Sec Delay but during it, since it will be visible in that mode. Then After the 3 Sec Delay Release the Mouse Press.

Thanks, yes now it is able to capture but I am getting the below error. Is that something I am missing. Appreciate your help.

Untitled

Error : Click ‘SPAN’: Value does not fall within the expected range.

@nilam.dnaik What are you performing before this click Activity?

Use Hover activity before click activity

Below are the activities

@nilam.dnaik What error do you get ? Is it the same errro?

yes same error.

@nilam.dnaik Can you try adding a Delay Before of 3 secs in Click Activity and also Set Simulate Click to true and check if it works?

Yes it worked. Thank you so much for the help. I have managed to click on the buttons. Trying to put these activities in the main code & will see how it works.

1 Like

Now I am facing one different issue. Each Item below is having this config button. Dynamically I am passing the variable to find element & Hover activity but the click activity do not have any such variable. & Every time it clicks the Config button of Memory though it is Hovering on DC Persistent Memory. What I noticed is the selector has an idx=2 always & thatswhy it is clicking on Config button of 2nd element always.

<webctrl css-selector=‘body>app-root>div>div>app-create-offer>app-structure>app-template-model-c>div>div>div>div>div>div>ul>app-hardware>ul>app-class-option-type>li>div>app-icon-set-root>span>app-offer-icon-set>app-popover>form>span’ idx=‘1’ isleaf=‘1’ tag=‘SPAN’ />

In the Edit selector I do not see idx as an attribute to which I can pass the value. Can you please guide on this.

Untitled

@nilam.dnaik Open the Selector in UiExplorer

Thank you for your support. Managed to achieve all the activities by passing variables dynamically.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.