Does Regutil.exe still on working?

Hi everyone,

In conclusion, I solved the issue bit it’s weird. Please see the solution in bottom

Q: I have a question that does the tool Regutil.exe still working enabled?

Recently My company bought a Robot and need to activate it. However, It seems the old instruction seems not working anymore. Instead, using the UiPath.LicenseTool.exe for related operations.

For example:

  1. Previous(Version19.4.4): Regutil.exe get-info (not working)
    Present(Version19.10.2): UiPath.LicenseTool.exe info(Instead)

Due to be identical with the development environment, I had to degrade the Robot from 19.10.2 to 19.4.4, then I met the problem that I couldn’t use the old instruction to activate, get-info.

Solution:
I solved the issue, but it seems weird that I installed the latest version(19.10.2) first. Then copied the LicenseTool.exe and other related files.
Uninstalled the latest version(19.10.2) and installed the version I required(19.4.4), then moved the files I just copied in the last step to the folder(UiPath/Studio/)
It worked, but took some time.

I would wonder to know is there any better solution to do it?

Thanks in advance!

2 Likes

Hi @opas1216

With the 19.10 release we changed our licensing solution, hence UiPath.LicenseTool.exe will replace Regutil.exe. But activating a license with regutil should work for the 19.4.4 version. What license were you trying to activate? For Studio and Robot stand-alone licenses it should still work. For Orchestrator, you should use https://activate.uipath.com/orchestrator for versions <19.10.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.