"Desktop has been disconnected while performing UI action" error while running Lesson 2 Practice 1

I’m going through the Lesson 2 - Practice 1 Walkthrough and I’ve completed the practice. I can run the workflow, but the problem is, after I selected either Yes or No, it will just launch the notepad, and after a few seconds (around 30 seconds), it will display the error

Main has thrown an exception

Message: Desktop has been disconnected while performing UI actions.

Source: Type into ‘editable text’

Exception Type: ElementOperationException

UiPath.Core.ElementOperationException: Desktop has been disconnected while performing UI actions. —> System.Runtime.InteropServices.COMException: Desktop has been disconnected while performing UI actions.
at UiPath.UiNodeClass.WriteText(String text, UiInputMethod inputMethod)
at UiPath.Core.UiElement.WriteText(String text, InputMethod method)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I’ve tried restarting UIPath but the same error still persists. Hope anyone can help.


I have no answer but you may feel better knowing I have the same problem. Misery loves company, so I have heard.


haha LOL… I definitely feel better now haha

So anyone from UIPath can help us on this issue?


Can you attach your workflow?

Hi Cosmin,

I tried to attach the workflow xml file here but I got the message “Sorry, new users can not upload attachments.”

Is there any way around this?

Are you using rdp? Have you tried this?

You seem to have the same problem like in here: Input to Browser fails when remote desktop is not connected - #11 by selrac

Just read more, click more and you’ll be able to attach.

1 Like

I’m not using remote desktop. The UiPath software is running on my local machine.

I can upload now, here’s the file

Main.xaml (15.6 KB)


like badita mentioned we usually see that error when working with RDP. Sometimes if you are working through RDP the grafical interface doesn’t get generated and can cause that issue.

Do you by any chance have an antivirus installed and can you specify your OS?

The workflow runs fine on my system so we have to investigate.

There’s something else going on there.

  • the RDP trick does not help
  • LoginToConsole is set to true

@imin Is there any other workflow involving UI Automation (click, type - without Symulate Type) working?

I have Microsoft Security Essentials & Panda USB vaccine running. I’ve tried disabling them both but the error is still there.

I’m using Windows 7 Home Premium 64 bit.

Hmmm… is Open Application considered Ui Automation? Because Open Application is working. In this issue, notepad is launched, but the error is when ‘Type into’ is trying to write something in the notepad.

I’ve tried running UiPath as administrator just in case, but the error still persists.


Do you have KB2533623?

I have the same problem. No. That update appears to have been superseded by KB2758857.

Hi All,

I am also facing the same issue “Desktop has been disconnected while performing UI actions”,
The scenario is there is two application 1. web application and 2. SQL server, 1st open the we app and do some activity and then go to SQL and execute some queries. and finally come back to web app and do some activity. the problem is SQL queries is taking time to execute (30 m - 3 hr) and the system gets locket out.
one more thing I am using RDP system

Any suggestion will highly appreciated

1 Like


I am getting the same error. Any help?

Thanks in advance


1 Like

Could you post the version of Uipath Studio that you are using?

My version is 2017.1.6309


1 Like

Seems that is a problem with version 2017.1.6309 and some version of windows 7.
This will be fixed in the next release.


1 Like