Disconnection error


#1

Hello,

I am trying to execute a workflow on a VDI. I need to perform some actions on a desktop application and it works perfectly when it appears on the screen while executing it. The problem is, when I tried to execute the workflow with the remote session running disconnected from my computer, it appeared the following message:

“UiPath.Core.ElementOperationException: Desktop has been disconnected while performing UI actions. —> System.Runtime.InteropServices.COMException: Desktop has been disconnected while performing UI actions.\r\n at UiPath.UiNodeClass.WriteText(String text, UiInputMethod inputMethod)\r\n at UiPath.Core.UiElement.WriteText(String text, InputMethod method)\r\n — End of inner exception stack trace —\r\n at UiPath.Core.Activities.TaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)\r\n at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)\r\n at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)”,“timeStamp”:“2017-01-20T12:44:19.6089432+01:00”,“level”:“Verbose”,"

I don’t know what this is about. I’d appreciate any help. Thank you.


#2

Hi,
Do not minimize or disconnect the remote desktop connection before starting the execution on it.
Signoff user first, then start the execution.
Let us know if is working.
Thanks


#3

Hi Cosmin,

Thank you very much for your answer. I tried what you told me but it hasn`t worked either. The process works perfectly while being screened but it fails when I try to use the task scheduler and run it in background.

The exact moment it fails is when I try to log in to the first application I need, using “type into”. I have tried adding the argument “executor” or “monitored” in the task scheduler, or using the activity “Launch workflow interactive”, but none of this worked. I dont know if I should make changes in the configuration due to for example some activities as "type into" are not compatible with processes running in background or if, on the contrary, it could be some possibility I dont know yet that could work, allowing me to keep the original configuration.

Thank you very much,

Carlos.


#4

Hello,

Please see Here

@badita indicated there that "that’s a know limitation for Community Edition. The service is running only under your user. "

@aksh1yadav posted This and it might be useful too

Regards,


#5

First

  • background automation (simulate type, window messages, file processing) will work
  • regarding the scheduling issue I need to check. I don’t have CE installed so it will take some time :).

#6

Yes, It’s a limitation for Community Edition, however I think the error is actually ‘Access Denied’ or ‘Resource in Use’.
I am assuming @c_cumplido has Trial Version? Do you have UiPath Robot installed as a Windows Service?


#7

Hi Lavinia!

Thank you for answering. Yes, I have the trial version, but the platform, not the community edition. I don’t know what Uipath Robot installed as a windows service means.

Thank you!


#8

Hello,

I see you have been dealing with remote session issues, I am trying to execute a process which interacts with a citrix environment in a remote session. I cant manage to get the process running when it starts performing in a citrix environment.

Has anyone had this problem before or know how to work with it?
Any help or tip will be very useful. Thank you.


#9

Hi, @Gabriel_Tatu

Try to execute bot when i close/disconnect rdp.

Facing same issue, Tried all thie method given in forum like,
1.changing register value as 2 for rdp suppresmode
2. Interactive invoke workflow
3.Config RDP timeout to create user session

Strange thing is bot only stop at TypeInto Activity for the windows application(before this steps bot works as usual), if i use same TypeInto for Notepad it works.

Any thoughts on this?