Desktop has been disconnected while performing UI actions

Hello…

I’m using windows 7 and UI Path community with version 2017.1.6309 (i’m not using a remote connection, im working in my local desktop).
When i try to interact (write a text value in some text field) with local applications like notepad++ or SAP i receive the following exception error:
"Main has thrown an exception
Message: Desktop has been disconnected while performing UI actions. "

Someone can help me with this issue? It is a Ui Path bug or it is something else?

Best reguards.

Try searching the forum for that error first as there are lots of articles.

Well, i did. I didnt find any solution to my problem, since i’m not using any remote desktop connection and for that reason i posted this.

If you find this error, i think this is a UiPath bug. The solution was to unistall the latest UiPath Studio version and install the version 2016.2.6274.

Best reguards.

2 Likes

Hello,
I have the same issue. Where can you find the version 2016.2.6274 of UiPathStudio?
Best regards,

Could you please send the logs?

1 Like

Ricardo, can you please tell us the steps that you take? How do you start the process? How do you lock the screen?

1 Like

I didn’t save the logs since i unistalled the newest UiPath Studio and installed the version before, and now it’s working without any problems. I took the normal steps to interact with my application (in my case a SAP application). Then i just tried to interact with Notepad to check if this problem was only happening with SAP, and i was getting the same error, so i think this is a UiPath problem.

The error occured after i open the SAP or the Notepad application when trying to write in some element (for example writting in Notepad Text Field or in a SAP Field). I could identify the elements, but when i start the process (using Run Button) this error was always presented when the robot tried to interact with the elements.
I will be available for any questions,

@andraciorici If you want i can send you the Notepad Process that i used to test this.

Best reguards.

Hello @matyohan ,

I think you can ask your UiPath client manager for that UiPath Studio version.

Best reguards

15:24:23.0123 Info {“message”:“example execution started”,“level”:“Information”,“timeStamp”:“2017-05-11T15:24:22.9593563+02:00”,“windowsIdentity”:“JWA\yohan.mathis”,“processName”:“example”,“processVersion”:“2017.1.6340.27671”,“fileName”:“Main”,“jobId”:“a5fe9850-1310-4a6b-8784-8c483b8cba1b”,“robotName”:“JWA\YOHAN.MATHIS”}
15:24:53.4463 Error {“message”:“Type into ‘editable text’ : Desktop has been disconnected while performing UI actions.”,“level”:“Error”,“timeStamp”:“2017-05-11T15:24:53.4463073+02:00”,“windowsIdentity”:“JWA\yohan.mathis”,“processName”:“example”,“processVersion”:“2017.1.6340.27671”,“fileName”:“Main”,“jobId”:“a5fe9850-1310-4a6b-8784-8c483b8cba1b”,“robotName”:“JWA\YOHAN.MATHIS”}
15:24:53.4603 Info {“message”:“example execution ended”,“level”:“Information”,“timeStamp”:“2017-05-11T15:24:53.459306+02:00”,“windowsIdentity”:“JWA\yohan.mathis”,“processName”:“example”,“processVersion”:“2017.1.6340.27671”,“fileName”:“Main”,“jobId”:“a5fe9850-1310-4a6b-8784-8c483b8cba1b”,“robotName”:“JWA\YOHAN.MATHIS”,“totalExecutionTimeInSeconds”:30,“totalExecutionTime”:“00:00:30”}

Hello @badita,

Do you have any tips to avoid this issue?
A link to download a older uipath version?

Best regards,

Hey @badita,

Last relase solved my issue.

Thank you for your help

1 Like

this problem im also facing , uipath company, please resolve this problem

1 Like

There can be many reasons for this problem, so a few things should be checked to know the actual one:

  • Are you using an attended or unattended robot?
  • Is the robot connected to Orchestrator? Is that connection done through a VPN?
  • Do you have a sample of the workflow that throws that error?
  • Is it possible to share the execution logs (the ones in AppData\Roaming\UiPath\UiPath\log) for further investigation?

Hello all ,
I am currently working on Level 3 assignment 1. Till now everything was working fine. Now suddenly without any changes in the workflow am getting below error.
“Desktop has been disconnected while performing UI actions”
Note: Not using VM or RDP. Running on my local machine

Please suggest me the solution for this…

Thanks,
Anush Nayak

If anyone facing this issue try enabling “Simulate type” checkbox…
It resolved my problem and it is working fine now…
Thanks for the help @nadim.warsi

3 Likes