Deploying UI Path on GCP Windows Server

I have a XAML that performs multiple UI interactions and have tried to deploy it on cloud via UIPath orchestrator (unattended robot). The problem I am facing is that:

When my remote session is up the Robot works fine but when I close my remote session the robot fails the execution with timeout reached error. I tried to run the bat file with RobotLocation -file fileLocation but this also works only if the system is opened in a remote session (basically manual connection).

I have tried so many things to get it working but all of it fails. Can someone who’s deployed a UIPath Studio Project using Orchestrator in GCP tell me a way to do so?

Thanks in Advance.

Hi,

please set your robot setting in Orchestrator as below

even you close the remote desktop. the session in robot server still on.

Hi this didn’t work as well. :frowning:

may I know what kind of process that didn’t worked?

I have sequence of processes:

  1. First one sends an email
    and
  2. Goes to a website and does some button clicks.

First process runs fine but it gives Timeout Exception for the second process

no OCR, No image involved.

what was error message?

Timeout reached.

RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at UiPath.Executor.BaseRunner.EndExecute(IAsyncResult result)
at UiPath.Executor.InProcessRunner.EndExecute(IAsyncResult result)
at UiPath.Core.Activities.ExecutorInvokeActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

This was the error message.

Here is the xaml script:

“<?xml version="1.0" encoding="utf-16"?><ClipboardData.Data><scg:List x:TypeArguments=“x:Object” Capacity=“1”><p:Sequence VirtualizedContainerService.HintSize=“375.2,308.8”><WorkflowViewStateService.ViewState><scg:Dictionary x:TypeArguments=“x:String, x:Object”><x:Boolean x:Key=“IsExpanded”>True</x:Boolean></scg:Dictionary></WorkflowViewStateService.ViewState><p:WriteLine DisplayName=“Write Line” VirtualizedContainerService.HintSize=“333.6,62.4” Text=“This is just a hacky way to run our script.” /><ui:InvokeWorkflowFile ContinueOnError=”{x:Null}" DisplayName=“Invoke UIInteraction workflow” VirtualizedContainerService.HintSize=“333.6,113.6” UnSafe=“False” WorkflowFileName=“UIInteraction.xaml”>ui:InvokeWorkflowFile.Arguments<scg:Dictionary x:TypeArguments=“x:String, p:Argument” /></ui:InvokeWorkflowFile.Arguments></ui:InvokeWorkflowFile></p:Sequence></scg:List></ClipboardData.Data>"

try set Yes on login to console.

Yes tried this as well. No Effect. :frowning:

Hi @spidey - Please sign out (not disconnect) all the users from VM and then trigger the process from Orchestrator.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.