Default package sources keep resetting

My default package sources keep resetting. I select all four here, but whenever I close and restart Studio it changes back to just Local and Orchestrator Host. This started happening after I upgraded to 19.10 and connected to Orchestrator so I’m not sure which is causing this.


1 Like

Usually these two packages sources will be disabled by default that’s why buddy
Kindly have a view in this thread for more details

Cheers @bzilch

I get that but when I check them to make it a default it keeps resetting. How can I permanently keep them as a default package without having ot check that box every time I start studio?

Yah we can do with Manage Feeds option
Where open the studio and go to settings tab in start menu where click on the Manage Sources option and enable them

Cheers @bzilch

I do that, but every time I open Studio they are unchecked. Is there anyway to check them permanently?

1 Like

I hope Only local and orchestrator feed will be kept enabled by default if the studio is activated with license provided in orchestrator
While the Official and Go feed will be disabled by default

For more info on this

Cheers @bzilch

1 Like


I understand that the Official and Go feeds are disabled by default.

My issue is, like in the case of @bzlich, that these particular feeds are automatically unchecked when I restart the Studio, even after having been once enabled through settings. Currently I cannot make them remain selected.

One thing is clear: Orchestrator changes this. The Studio which is not connected to the Orchestrator keeps the setting.

Questions are why it happens and how I can keep my setting of Official and Go feed.


I found out that 19.10.3 LTS changed this feature back.
Now it keeps the setting as you choose.

Thank you, UiPath guys, for listening to users’ voice.

Upgraded to 2019.10.4 and this issues is back.


If you want to control this from a user by user setting, you can do the following:

  1. edit this file in notepad %APPDATA%\NuGet\NuGet.Config (the path should be C:\Users<your username>\AppData\Roaming\NuGet\NuGet.Config)
  2. add a key for MyOfficial and MyGo! and make sure to remove the / after workflow and add the / after v2

Restart Studio and it should be retained going forward.


You can also add this within the user interface of Studio, but I figured you would want a copy/paste method that could be pushed out to all users in an organization.


I also have this issue. When I try adding a user defined package source named MyOfficial with the same URL as Official, I get “Package feed source ‘’ must be unique.” Is there a workaround?

Yep, same issue here. Enabling the ‘Official’ feed via Package Manager or via Settings > Manage Sources will be forgotten after a reboot. (Studio 19.10.4)

We used to have a behavior where all feeds except Local and Orchestrator would be automatically disabled when connecting to Orchestrator. The reasoning was to promote internal / customer feeds. This behavior has been removed in 20.4 after we introduced Governance Policy support. With Governance Policy you can control which feeds are enabled across the entire company. Even without a policy setup, feeds will no longer be disabled after connecting to Orchestrator.

So the only solution is updating to 20.4.x? But 2019.10.x is the LTS version, 2020.4 FTS is not what I can recommend my customers for Enterprise environments.

I can’t believe this is a feature / designed behaviour :face_with_raised_eyebrow:: Always overwriting user settings on each reboot. This will break all our Robots because the packages will not be found.

Even if I open the source code (first get the errors about missing dependencies) and manually add the Official feed, there’s an issue. Studio will now see the packages as already present. So you can not save the (fake-)changes in manage packages (Save-button greyed out). Therefore the required packages will not be downloaded to orchestrator/local and still won’t be available after the reboot.

The only workaround is:

  • Open the project
  • Change all dependency versions and save (while praying version conflicts won’t break anything in your workflow/project.json)
  • (Then these ‘new’ dependencies will be available in Orchestrator).
  • Next, change back to the actual desired package versions, save (saving is now possible, because it is a change in versions, so the ‘Save’ button is not greyed out)
  • The actual desired package versions will be downloaded to, and available on Orchestrator from now on.

However, you will have to repeat this excercise regularly to keep up to date. And be carefull of dependency version conflicts.

Just stumbled across this, since we want to upgrade to 2019.10 LTS release and face the same issue…

Has anyone figured out another way of handling this -other then the workaround “Whynotrobot” provided?
This workaround works, but I think this is highly unpractical for an enterprise environment.