Deal with internet explorer pop up for downloading file

whenever I select the tab “Save as” the selector is valid, but the robot cannot find the UI element, how can I solve this issue

Buddy @Dina.abdelhakam

Welcome to UiPath community buddy

Buddy its very simple as you can see it is getting to a new window, we have to use attach window, make a selection of that new window as element and then activities with click activity to select the tab buddy @Dina.abdelhakam

This would work for sure @Dina.abdelhakam

Hi @Dina.abdelhakam,

Try with dynamic selector

Hi @varunk
which attribute should be dynamic ??

Did that work buddy @Dina.abdelhakam

hello @Palaniyappan I tried that before and doesn’t work

Buddy can i see the selector been used @Dina.abdelhakam

Cheers

@Palaniyappan
“wnd app=‘iexplore.exe’ cls=’#32770’ title=‘Internet Explorer’ />
wnd aaname=‘Internet Explorer’ cls=‘DirectUIHWND’ />
wnd aaname=‘Save as’ cls=‘Button’ title=‘Save &as’ />”

yes buddy @Dina.abdelhakam

Buddy use activities within attach window and remove the cls attribute atlast and make aaname attribute as target element buddy this would work buddy @Dina.abdelhakam
and you can check with the target element here in the ui explorer (just for example) or you can even disable this pop up with settings in your explorer buddy @Dina.abdelhakam

Change the IE settings to ignore this popup. So that you will directly get the “File Saving” dialog.

Please refer this link.

2 Likes

@Palaniyappan could you explain more ??

Hi @Dina.abdelhakam
follow the given steps to disable the prompt for download, which actually here is bothering

Disable the File Download Prompt

  1. Open an Internet Explorer browser and click the gear icon to open Tools . (You can also press Alt + x to open Tools.) Then click Internet Options > Security tab.
  2. Click the Custom level button to open the Security Settings.
  3. Scroll down to the Downloads heading and select Disable for automatic prompting, file downloads, and font downloads.
  4. Click OK , and when asked if you are sure, click Yes .
  5. Click OK again.
  6. Close all Internet Explorer windows, and then re-open Internet Explorer and attempt the download again.

hope it helps

regards

Buddy better you can use Click image activity and drag the Save As image alone, and it worked for me as well, the reason it looks unique in font and color so it would be easy for the bot to identify the image as well, though its bit slower when compared to other methods, buts very reliable to them as well…Try this buddy this would work for sure buddy @Dina.abdelhakam
Cheers

If you don’t want to change your internet settings, try using the hotkeys for the download screen i think its ctrl+J to open the downloads screen, you’ll then be able to click on the save as / save options and input your filepath.

Hi @Dina.abdelhakam,

Using Uiexplorer you can take the selector & Save in variable
Use that

Unfortunately didn’t work :frowning:

it didn’t work :frowning:

Try to find the button using UI explorer. There must somewhere hidden in there, you just need to find the right one. This maybe related to dialog?

Simply, use click activity, take full selector of “Save as” button. It will work fine.