CV Type into Activity not working due to selector not found, but when debug it runs perfectly

Hello AI Compute Vision Team and Experts,

I have successfully connected and deployed robot on remote computer (virtual computer) using orchestrator. I have successfully publish one sample process (e.g. open browser and open application) to check and found working fine using robot on remote computer (remote computer opens the browser and open the application as well).

Now, I have one desktop application in that remote (virtual) computer which i already open by using start process and open .exe file in that.

After application open there is one text box in which i need to type static text which i successfully placed in screen scope. Now when i run this in debug mode it writes that static text in text box successfully but when i run my process using robot hosted on that virtual machine through orchestrator it is NOT typing in to the text box.

Please help.

Here i attached my application text box into which i want to write “8511”, my process from Ui Studio and Error when i run process through orchestrator.

Image CV CV1

1 Like

@kashyapvyas

Are you using community or Enterprise Edition ?

@lakshman

community edition

Hi @kashyapvyas
Use some relative element to type the number in the text box. I guess Employee ID will be fine as the relative element to write any number in the text box.
Just like this
image
Hope it helps!

1 Like

@anmolk171

I did try this but unfortunately no luck.

Please help.

@kashyapvyas Just one thing want to know. Is it necessary to use Computer Vision Activities?
You can change OCR engine just try to use Google OCR and just try to change the Scale of the OCR.
Hope it will help.

@lakshman suggested me Computer Vision Activities and based on its documentation it looks like full filling my need as well.

I do not know very much about OCR. Please help me to understand.

I just read about Google OCR and found that it is only UI scrapping (extracting strings) but i need interaction with my desktop application as well (e.g enter userid in text box, press login button, coming in next screen again entering employee number and hit search button, extracting data here and etc…

  1. Does Google OCR can be used in replacement of Computer Vision?
  2. Why everything (Computer Vision - CV Type Into Activity) is working fine while i am debugging from Ui Path Studio but not when running it from Robot?

@anmolk171 @lakshman can you please help me?

The error you get is “Cannot find UI element corresponding to this selector”, which means the actual window is not found by the Scope. Can you do a normal click (non ComputerVision) on that “LMIIgnition” window?

If you can’t, it could be from the fact that the app is running with elevated privileges, while the robot is not, so it cannot control it in any way, CV or not.

@Cosin

I can’t do a normal click on “LMIIgnition” window as it is running in remote computer (its a client application and it talks to the local server on that same machine) so i must have to use “Computer Vision Activities” to interact with that. Please correct me if i am wrong.

BTW, Why it is running in debug mode and not running without debug?

Can anyone help me on Skype?

@Cosin
@lakshman
@anmolk171

Please help.

From your screenshot, the Scope is looking for “LMIIgnition” window, so it must be accessible to do a normal click. See if you can click in it anywhere.

Could you send us the workflow, or just the relevant parts, so we can investigate?

@Cosin

“CV Screen Scope ‘LMIIgnition.exe SVR-1694’” - It is just a auto generated display name (and non-relational name with my desktop app) when i select screen scope from Ui Path Studio. And I am unable to type/select anything without Computer Vision Activities.


@Cosin

Please help.

@Cosin

As I am Community Edition Orchestrator user, what are the changes i have to made in settings->deployment tab?

Is this (deployment settings) something which prevents me to run Robot on Remote Computer?

In CV Screen Scope there is one property called APIKey, do i need to add any key here?

Please help.

Here below attaching settings tab of my orchestrator:

@lakshman @anmolk171, do you have any idea about this? Can you please help?

Hey @kashyapvyas

This can happen if the user under which the robot runs on the virtual machine has less privileges than the target application.
Can you try running the robot as an admin or as the same user as the target application?

Can you paste the selector used by the CV Screen Scope?

Thanks.

@Ion_Miron

If you go on top of this thread and scrolls down you will find selector used by the CV Screen Scope. Please correct me if i am wrong.

Thank you for looking into it.