Currency Converter - Copy File Error Message

I keep getting the following error on the Currency Converter case study

Copy File - Could not find part of the path

I’ve tried multiple times and have followed the same instructions as the video but cannot resolve this issue. Any help or suggestions will be appreciated

Thanks

Welcome to the community!
This error can mean you are setting a path to a folder that dont exists or have white spaces in your path… Do you have the Reports folder in your project?

Yes, the Reports folder is in the project. What do you mean by white spaces in the path? I’ve even tried to create a new project folder with all the files and redirected from this new folder to all the areas in the task automation

do you get the error when you try to save the file as “Reports…” right? make sure you have the \ in there…

Yep, that is in there. I will send a screen shot later today as the program is on my home computer

image

this is the error

are you 100% sure the path is ok? and it is in a folder that uipath has permissions?

I believe it is ok. How would I know if UiPath has permissions or not?

copy and paste that full path in a Windows Run dialog box:
image

Thank you. I will give it a try.

same problem here. I have followed bcorrea’s instructions to test if UiPath has permissions and it does. Still can’t solve the problem.

also same problem

solved it by adding full path at the beginning
example:
C:\Alex\Personal\uipath\reports<[Notes.Sheet(“Date”).Cell(“YYYYMMDD”)]><[Saved.Values(Of FileInfo)(“TemplateInfo”).Name]>

Hi, I am with the same problem…

I’m taking the UiPath RPA Starter course, but in the first automation I did, I’m getting the error ‘Could not find a part of the path’, in Copy File Activity, I tried to uninstall and install again but it didn’t work, can someone help me?

Something went wrong with an Action.
Activity Copy File (Copy File) failed:

Could not find a part of the path ‘C: \ Users \ vitor \ OneDrive \ Desktop \ RPA \ UiPath \ Currency-Converter_Working-Files (1) \ Report.xlsx’.

Exception Type: System.IO.DirectoryNotFoundException

RemoteException wrapping System.IO.DirectoryNotFoundException: Could not find a part of the path ‘C: \ Users \ vitor \ OneDrive \ Desktop \ RPA \ UiPath \ Currency-Converter_Working-Files (1) \ Report.xlsx’.
at System.IO .__ Error.WinIOError (Int32 errorCode, String maybeFullPath)
at System.IO.File.InternalCopy (String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
at System.IO.File.Copy (String sourceFileName, String destFileName, Boolean overwrite)
at UiPath.Core.Activities.CopyFile.Execute (CodeActivityContext context)
at System.Activities.CodeActivity.InternalExecute (ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute (ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody (ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

1 Like

Hi, welcome to the community!
Maybe you have a problem using that OneDrive path…

I tried to put out of OneDrive and the error continues …

Could not find a part of the path ‘C:\Users\vitor\Currency-Converter_Working-Files (1)\Report.xlsx’.

Can you try using a relative path to your project folder for a test? Copy the file in the same folder of your project and try that.

Hi Vitor, I try at the end of the path completing the report archive with “xls” instead of “xlsx” and it worked. Maybe that is your problem.

Regards,

Ezequiel

1 Like

Hi, I was facing the same issue while trying this case. But, just like other experts suggested: creating a “physical folder” is critical.

In another word, I added a folder called “report” under this particular UIPath Project and it worked out. Maybe @UIPath team would consider adding a note/pointer on to the video, so whoever is trying in the future won’t be stuck.

1 Like

After a lot of trial and error I was able to get this to work on version 2020.4.3
I had to insert the “Folder” option from Templateinformtion then included the /Reports/ folder with the name (see screen shot). This worked without error.
<[Saved.Values(Of FileInfo)(“Templateinformation”).Folder()]>/Reports/<[Saved.Values(Of FileInfo)(“Templateinformation”).Name]><[Notes.Sheet(“Date”).Cell(“YYYYMMDD”)]>.xlsx