Currency Converter First Automation Problem

When I run the 1st step of the bot that opens the Excel file and copies the data in from the csv file the UiAssistant says job started processing, however it never stops and does not open Excel with the data copied in from the csv file. I’ve tried changing the file path to desktop or moving it to My Documents folder to no avail.

can you please post a picture of the wf?

Below is a snapshot showing the project screen and below it text of the full path of the Excel file.

C:\Users\non0238\OneDrive - Takeda\L-Shire\Documents\Report.xlsx

I was able to get the first automation to work by changing the path of my files. The program was looking for the files to be in the UiPath sub-folder under Documents. The file path that worked is as follows:
C:\Users\non0238\OneDrive - Takeda\L-Shire\Documents\UiPath\CurrencyConverter\Report.xlsx

I am now having trouble with the step of retrieving conversion values from Google. When I drill into the Save to under Get Text USD I do not get an option for Conversion, only Indicate in Excel or Custom Input show up.

I go that conversion but at the end when I run the automation, it stopped at the GET TEXT, shows it doesnt run so error

any idea, what can be done?