Crome Extension Issue for Robot Only

I am facing the chrome extension issue. The following is the issue:
“UiPath.Core.BrowserOperationException: Cannot communicate with the browser, please check the UiPath extension”

I have UiPath Robot only so I cannot install extension from Studio. I am running the package from the tray.

Things I did to solve the issue by myself:

  1. Removed extension and installed again (multiple times).
  2. Cleared browsing data before execution.
  3. Update the package few times.
  4. Restarted my machine.


Check below for your reference

Hope this may help you



Hi @Arun_Kumar4,

What we know is you tried to reinstall and checked if the extension worked when you were logged in. Is that correct?

You were logged in a Robot I assume. If the robot fails then, another cause for such an annoying error is how the robot VDI / server / machine is affected by the group-policy.

If your company group policy is to not allow extensions to be active after a restart or after the user has logged off then everytime the chrome extension will be removed forcefully and you are left with the companies default windows install.

If this is the case, you will have to talk to the IT department to help with switching this off for your robot machine.

I didn’t get the “Logged In” part. I tried deleting/removing extension from chrome and downloading/adding the extension again. I did that multiple times but it didn’t worked. I followed the given link to add the extension:


What I mean is the moment you log off from that machine, the group policy can trigger a delete extensions routine.

So when your robot logs in again there is no extension in chrome and you get this error.

I dont mean this is the error, but this was what we found when we had the same error.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.