Create Form Does Not Open When Process is Running

I am trying to create a proof of concept process that goes through a data table row by row and displays a PO number in a form. I based my design on an example I found that runs correctly. However, when I run my process, the form never opens up. Am I missing something that allows the form to open up and be viewed during the run?

You can see the PO numbers get outputted before a crash, but the form never opens.


Did you click Open Form Designer and build your form?

Yes very basic form has been created. I am not sure if I am passing data in correctly, I based it on another example

I feel like this value for Property Name is incorrect but that was autopopulated

How many rows are in in_SAPDT?

After I filter the data table, it is 225 rows. But they are poorly formatted so they are widely spaced out, making the excel file longer. But that should not matter since it is in a data table structure, not excel

Try a newer (or if you’re on the latest) older version of UiPath.Form.Activities

I am on the latest version 2.0.3

I tried to downgrade to 2.0.2 but this did not help. The form still did not open when I ran the process

Create a new XAML file, put just the form activity, configure the form but don’t provide any inputs. See if it opens. If it does, then you know the issue is something with the way you’ve configured it.

I created this test xaml with just the form and a text field and the form does not open when I run this file

You’re closing the form designer before running it, right?

Are you getting any errors with this one?

Yeah I am. No errors, it runs for 2 seconds and then finishes executing

Try version 1.8.0 of UiPath.Form.Activities

Going to 1.8.0 cause the form activity to be missing. Also, do I need the UiPath.FormActivityLibrary package?

It’s not missing it’s just a lower version so the code isn’t the same. Delete that activity and then re-add the Form activity. No, you don’t need FormActivityLibrary.

I deleted the activity and put this Form activity in…but I do not think this is what I want. This does not allow me to design the form using the GUI

Use the same activity - Create Form.

It doesn’t exist unfortunately

Yes it does. It’s the same thing I’m using - v1.8.0 of the package, and the Create Form activity. Do you have your project set to modern?

No it is not set to modern

Well set it to modern and then see if you see the Create Form activity.