UiPath Studio Error - Could not connect to UiPath Robot Service


#1

I downloaded the trial version three days ago and so far it has been working fine. Today when trying to Run a UiPath project, this box pops up:

I have tried to start the Robot Service but the option to do so is disabled as shown in the following image:

I have tried as well to run the Robot from the .exe file but nothing changes.

Does anyone know how to solve this problem?

Thanks


#2

Hello!

Try to do the steps below:

1) Restart your machine
2) Try to start the service as Administrator
3) Reinstall Uipath Studio

Let us know If worked!!

Regards,


#4

I have the same issue. I know it has been addressed in different threads but is there not a solution for people like myself who do not have administrator rights. Getting the Administrator involved every morning when I turn on the machine is not viable as I am sure you understand.

Is there a way to have the Robot start without using the Administrator? (or at the least only getting the administrator involved once and then not have to use them again?)

Regards


#5

Hey @Majorman

Just let me know what is the “start type” You have assigned. Basically bydefault “UIRobot” service will start Automatic with dealyed options. so need of manual start.

For reference make sure the same things you have

Still if you are facing the problem then Make sure the reinstallation with admin rights

Regards…!!
Aksh


#6

Thanks @aksh1yadav for getting back to me.

My UiPath Robots service is set up exactly the same as the imagine you sent with Automatic (Delayed Start). However, as I am not an administrator the buttons are greyed out. Also the Service status is stopped and I am unable to change this.

I did not understand the end part where you say “Still if you are facing the problem then Make sure the reinstallation with admin rights”

Does this mean I will have to reinstall via the admin rights every time I restart the Computer? Getting ahold of an administrator takes a few days where I am so I need to avoid it or at the least only call them in once.

Regards,


#7

No it is not like that what sometimes happens if you have installed it with your user privileges and you are not admin you will not be able to start the service mostly at the time of installation you will get an alert that uirobot service not has been started kind of.

and re-installation again you have to do once not everyday, hope this will get resolve.

Regards…!!
Aksh


#8

@aksh1yadav

When I initially downloaded the programme, I did it with Administrator rights and not user privileges. So on that basis I should not have an issue with the robotic service not starting surely?


#9

Yeah so may be something went wrong just may be you an repair the installation. Just run again the setup.exe and select the repair installation.

Regards…!!
Aksh


#10

thanks!


#11

Reinstalling did not work for me at all. Also to note, when you are not able to start Robot service, setting for tray icon for Uipath Robot is also disabled (obvious) . We reached out to UiPath support and they provided us instructions on how to resolve it. Our machine was a Window 7 VM ( vmware based) . Team followed the instructions mentioned below and they were able to resolve the issue -

  1. Go to Start > Run > and type regedit.
  2. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. With the control folder selected, right click in the pane on the right and select new DWORD Value
  4. Name the new DWORD: ServicesPipeTimeout
  5. Right-click ServicesPipeTimeout, and then click Modify
  6. Click Decimal, type ‘180000’, and then click OK
  7. Restart the computer
  8. Open command prompt in elevated privileges.
    9). Navigate to UiPath msi installer directory.
    10). Execute command "msiexec /i UiPathStudio.msi /qr"
    11). Please keep on check that the installer does not roll back.
  9. You should be able to start the service now.

Cannot connect to UiPath Service error
UiRobot Service error
#12

Hi Forum,
I´m looking for a possibility to start the the UiPath Robot (via Orchestrator or Studio) for Windows 10 user without admin-privileges. Has anyone experiences with that issue. With my Tests, I was unable to connect to the Uipath Robot Service on a non admin account. The robot came with the UiPath Studio installation.

Thanks,
Stefan


#13

My suggestion is to download the trial from www.uipath.com and start to automate that process. If you get stuck don’t hesitate to search for the answer in the knowledge base http://www.uipath.com/kb-articles | UIpath or ask on chat/support.

I hope this will helps you.

Regards
SarahJohn