Could not start executor. The user name or password is incorrect. (Exception from HRESULT: 0x8007052E) - Troubleshoot steps

Please follow the below approach:

1. Kindly open the Robot settings in the Orchestrator window & reapply the Robot Password.
You will have to provide both domain\username and password for Orchestrator to create a Remote session on Robot /Studio machine.

Username - If your Robot username is in a domain please write it in the “domain\username” format.
Password - Provide the password to login to the Host machine.
Verify now

2. Go to services.msc and look for the service “UiRobot” and check under what useraccount it is running.
Please change the account under which UiRobot service was running to localsystem . (Identify if the Robot is running under robot service account, changed that to local system)
localsystem (which is default configuration) this ensures that service has access to all local resources.
( Run -> Services.msc -> UiPath Robot )

Restart the Robot service.
Verify now

3. Verify the encryption key in the web.config file. (In case if you have performed an upgrade, thereafter you are facing the issue)

Cross check with the config which you have taken as a backup. 

4. If still, you are facing the Issue, kindly re-provision the Robot again to solve the Issue.

If none of the above helps, please raise a support request with tech support of UiPath
Technical Support: Contact Technical Support


i did as per your steps but its still not working@PranayaSahu

it is running using uipath robot(agent)

1 Like

I have the same problem.

Hi, …not working even after tried all … it is fine if I start the process from Systray (my PC), but it doesn’t from Orchestrator.

Any solution to this?


I tried all the steps provided above but still facing the same issue. Please help

Hi @ovi
Can you look into this issue, please?
Attached the screenshots of the error.

I have tried with different tenants it is also giving the same error.
The process is working with UiPath Robot tray and UiPath tool but getting the error in orchestrator. (10.4 KB)


++ @PranayaSahu

If you are able to execute from Robot Tray using a specific user , than the same user details to be provisioned while creating the Robot in Orchestrator.
Try out the step 4 , delete & recreate , reapply the Robot. If still facing issue raise a support request.

1 Like

@PranayaSahu, Tried all workaround including delete and recreate, reapply robot. nothing works. Since am using the trial version, I cannot get help from support team. The only option is through this forum. Looking forward for a solution.

Thanks @PranayaSahu
The problem was with the UiPath version, I installed the latest version and now things are working.

1 Like