Client Security Hash Assignment Error in getting Transactions


#1

Hi, I’m having hard time to understand how the DataRow[] is accessible in the GetTransactionData.
I extract the data successfully in ExtractData.xaml and I can print it to Output and see that it’s correct. I assign it to an argument that’s a data row array.
How is this data row array supposed to be accessible in GetTransactionData?
When ExtractData is invoked from Init, what argument value should it have? Right now I have nothing in there.

I am still a bit confused about what the GetTransactionData.xaml is supposed to do…


#2

Solved it. I changed the importing argument to Data Table (in Extract Data Table) and gave it TrasactionData as an arg value.
Only in GetTransactionData I assign the Data Table to Data Row Array. And then follow the instructions. Works.


#3

hello trixy, can you explain about assign data table to data row array? which argument that u change?


#4

Hi @trixy
I think I have almost the same issue that you. I tried to fix it since Long time now but cant understand where is localized my mistake.

The bot work well untill the get Transaction Data workflow.

The ExtractDataTable workflow works and find 12 Work Items. till here no issues…

But directly after that Extraction. the Robot go to the “Get Transaction Data” Workflow and the if activity doesn’t work.

I already tried every tips I think mentionned in existings Topics in the Forum. Could someone please have an idea from where my mistake. Config File? Arguments?..
So the bot say that there is no Data to process but it find 12 Items…?

here my imported arguments

and here the “Get Transaction Data” Workflow :

I would be very glad if someone can help me to resolve my issues and maybe it will be profitable to others users.

Thank you
Jawahar