Uipath Academy - Level 3 - Assignment 1 - Extract DataTable to Get Transaction issue

datatable
studio

#1

Hi Guys!
I have one issue with the first assignment and i am locked at the step “Get Transaction Data”. I tried to fix it since Long time now but cant understand where is localized my mistake.

The bot work well untill the get Transaction Data workflow.

The ExtractDataTable workflow works and find 12 Work Items. till here no issues…

But directly after that extraction. the robot go to the “Get Transaction Data” workflow and the if activity doesn’t work.

Unbenannt2

I already tried tips mentionned in existings topics in the Forum. Could someone please have an idea from where my mistake. Config File? Arguments?..
So maybe the bot say that there is no Data to process but it find 12 Items…?

here my imported arguments

and here the “Get Transaction Data” Workflow :

I would be very glad if someone can help me to resolve my issues and maybe it will be profitable to others users.

I think that my mistake would be in my ExtractWorkItem_Data Table, Am I right ? :

Thank you
Jawahar


#2

Use writeline activity and check the count of Wilist.If you didn’t get 12 then you did not assign the arguement values correctly @jawahar


#3

Hi, Thank you very much .

I find 12 Items with the wrtieline activity.
Maybe I made mistake in arguments values or variables?

Here my Extract WI DataTable workflow :


#4

In gettransactiondata you have passed this as an arguement.Check in GetTransactiondata


#5

It’s exactly what I did , Should I Change the Argument with a variable?

Many thanks @sreekanth


#6

Hi @jawahar,

Inside the GetTransactionData can you print the in_TransactionNumber and the WIList count in a writeline to see if they are passing the right values.


#7

Hi @PD2

thanks.
I did it and for in_TransactionNumber it finds 0 and error msg for WILIst.

I checked other Topic in the Forum. It seems that I have no value in WIList.


#8

It should be WIList.Count.ToString. The WIList is a datarow array hence you cannot print a collection like that.


#9

@PD2
Thanks for help. Oupps sorry now I write correct :
The WIList is empty
It is probably my Problem.
How could I fix this issue?


#10

There you go! So when invoking the GetTransactionData you are assigning a variable called datalist. I’m not sure what’s in your datalist, but you should be passing the WIList as an argument to the GetTransactionData


#11

@PD2
I understant the problem. My problem is I don’t understand how should I do if I want to transfer or assign the value or the DataTable extracted in this WIList.


#12

Set your out Item to WIList(in_TransactionNumber-1), because WIList index starts from 0 and Transaction number starts from 1. Try to reset the test data every time you debug the program after fixing something


#13

Hi @prankurjoshi & @PD2

Thank you to you.

Ok I understand Thank you.

I try it but still the same problem…

Could I ask you to see my main workflow to have your view?
Main.xaml (52,7 Ko)


#14

Main workflow looks okay you need to send me the specific screenshot of error. You can find the error in output window after the execution. Also log start and end message in every workflow, it will help you in debugging


#15

Thank you.

when I run in debug mode the Get Transaction Data workflow it’s like that :


#16

Also the error message in debbug mode when I run the entire main workflow is like that :
Main


#17

Send me the GetTransactionData.xaml or the screenshot for the same, Also please verify that you have items in in_WiList


#18

GetTransactionData.xaml (8,0 Ko)
Here my GetTransactionData.xaml

I think its my problem that in_WIList has no data. but my Extract Data workflow Show that 12 items have been found :
ExtractData


#19

you are missing a step in InitWorkFlow where you have to assign values to WIList which has Type=“WI5” AND Status=“Open”. That is why the in_WIList is empty. Go to PDD file and read it again.

image


#20

okay thank you.
Could you please explain what mean this sentence in the PDD File ? :

extract%20data%20table

I extract the Data Table and I use an assign activity but with which value? I have to create a variable ?