Client Security Hash Assignemnt : Data Scraping details coming as Null to Main flow

Hi Guys,

I created a sequence which extracted filtered data into a data table. Same data table I mentioned as an argument with ‘Out’ direction.

When I call this sequence from main workflow, it worked well and extract all information but while returning to main workflow, it return ‘Null’.

Can someone know is the problem?


Could you please check whether you passed arguments properly or not.

Buddy @s2stechsolutions

Welcome to UiPath community buddy

Kindly change the direction of that argument as In/out buddy
That would work for sure buddy

Problem is with extraction, datatable is having value till second last layer. When it reach to final layer, it is becoming Null.

I tried to change it to ‘In/Out’, didn’t make any difference.

Buddy @s2stechsolutions
Kindly check once with the argument passed to the last layer as you have…for that
Assign this out argument from the first layer a variable and change that variable scope to the whole sequence or flowchart…and assign that variable to the in type argument of the last layer buddy

Cheers @s2stechsolutions

Did that work buddy… @s2stechsolutions

I am doing something wrong, not able to figure it out where it going wrong.

I got solution. While loading datatable value, I was loading into variable. Instead of that I used directly into argument and I am able to pass data table values to main workflow.

Thanks for your time and efforts.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.