Data Table not coming across as output argument

datatable
activities

#1

I am doing Assignment 1 of level 3. I have extracted the work items using a data scrapper and that works. The extracted data table is not coming across to the main workflow as an ‘Out’ argument.

Main Sequence invokes “Get Extracted Data” with “ExtractedDataTable” as an Out Argument and in the “value” column I have “WorkItems” which is a data table. After doing the invoking, I would expect values in ‘WorkItems’ Data Table. But, I get Error like
"System error at initialization: Value cannot be null.
Parameter name: source at Source: System.Data.DataSetExtensions".

Please help. I have checked the data table in invloked sequence and that has values. Only that the values are not coming across through the ‘Out’ Argument mechanism to the invoking sequence.


#2

hey @narayanm

it should come. with thrown excecption clearly we can say you are either passing an empty datatable or wrong datatype.

for your reference attaching some samples for you :
Datatable out argument sample.xaml (5.1 KB)
dtsample1.xaml (7.7 KB)

Regards…!!
Aksh


#3

Hi Akash,

I recall having the same problem when I was doing the exercises, so within the dtsample.xaml I created a datatable variable and assigned it to the out argument. It was a one time issue I guess.

The following exercises I was able to work directly assigning to the out argument.


#4

Thanks a Lot Priya and Akash.

Once I assigned the data table to another variable, it worked.

Is always the case ? Then the documentation needs to say that any argument must be assigned to another variable and passed as ‘Out’ argument while doing data scrapping.

Thanks Again.

Narayan


#5

Hi @narayanm,

No its not like that, you can use the directly out argument variable also.
if you are trying to do some operation with that Datatable make sure the Datatable is object are created and its not null.
*Check the Datatable is null use this query isnothing(dt) it will return the Boolean value.

Regards,
Arivu


#6

Yeah it happens but not always you can clearly see with my above sample.
IMHO it always better ton create and initialize object so datatable initialization before its use will help mostly to avoid much other problems as well :slight_smile:

Because you have initialized it via variable assignment so now it is referring an object of datatable type.

No it is not always the case you can see in my provided sample for you but IMHO best practices to always initialize your objects to use it.

Regards…!!
Aksh


#7

Hi Arivu,

I did not add any other extra step to solve the problem.

I just assigned the data table created out of “Data Scraping” to another data table and used it as argument and it worked.

Yesterday, I straightaway used the data table created as argument and it did not flow thru to the invoking work flow. But, I did check the data table in the invoked workflow with ‘Message Box” and It did have values.

Regards


#8

Hi Akash,

I changed your sample o do data scrapping instead of building a data table. Then It did not work.

Just FYI.

Regards


#9

Another Issue about “WaitforReady” property of “Get Text.” Assignment 1 Get hash code.

I have followed the text below. Still, the workflow is not waiting for the page to open. Hence I get error. If I introduce a delay of 5 secs, then everything is good.

“Before getting the text from the web page, we have to make sure that the page is loaded, and all the elements are available. Add an Attach Browser activity. In the Do section, we’ll use a Get Text activity with the WaitForReady property set to Complete. “

Any comments welcome to solve this without using delay.

Regards


#10

hey @narayanm

as i said my post above initialization is always a good practice in my IMHO. but there might be a problem of screen loading or timout. are you trying just after scraping step that data you are getting when it is throwing an exception or not.

exception itself tells alot about its source.

Thanks

Regards…!!
AKsh


#11

I’m having issues with initializing the datatable via variable assignment. Can someone have a look on my invoke workflow? What am I missing?

Thanks in advance
Christoph

01_Testsystem.zip (4.7 KB)


#12

Hi @mangogul,

In GetDates.Xaml file Read CSV file Properties output you given wrong data table i think, can you check it

Regards,
Arivu :slight_smile:


#13

Great, thanks! Works.
Best regards
Christoph