Client Hash Code not working. Can I still upload?

Hi There!
I completed the entire Client Hash Code as per the walkthrough without any compilation errors. But getting lot of errors when I run it. I feel the argument binding is wrong or some of the activities are not the right ones. Because if I execute each functionalities independently (not within Framework) as separate processes, I am able to do them successfully.

Unable to fix the issues when they are integrated in the FW for quite some time now…
Question----if I upload my existing code, even if I dont clear the assignment, will I get access to the complete solution so that I can fix the gaps and re-submit? Will my submission unlock the next assignment?
How many times can I re-submit?
Pls suggest
Thanks
Nalini

Hi Nalini,

You need to reset the test data and run your full flow at least once in order to update the work items details to “Completed”, if not you will not pass it. I would highly suggest you solve the run-time errors so you are familiar with the framework.

You can upload many times as far as I know and the system will still check for you. But the completed walk-through only will be available once you pass the quiz and unlocked your next assignment. There are plenty of resource here alone in the forum or in YouTube tutorial.

Thanks for the response.
I get error in the very first step when I try to run my login file by clicking ( Run File)
I get an error:
Invoke Workflow File: Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities}GetSecureCredential’.

I think GetSecureCredential is for Windows Credentials and not Orchestrator Credential
Should I install the uipath.credentials.activities package also? If so it asks the Windows credentials
Please explain if you can.
Thanks

@Nalini_Pendyala

Yes you need to install Uipath.Credentials.Activities Package.

We are using some of the activities under this Package in one of the workflow called Get Credentials.xaml file.

1 Like

Thanks Lakshman
I did that. Then I get Hello Robot interface and it asks for windows credential.
So what exactly is that? So I gave my system user name and password in the Robot interface . A generic credential was created for me.
But the credentials I created as Asset in Orchestrator is not this and it is System1 URl credentials. Am I right? Pls correct me if I got it wrong.

Now I run the file in Debug mode, at Open browser it stops. And when the browser activity is accessed I get the error in a Dialog Box:
Open Browser.
Value Does not Fall within the expected range
and below are the details:
*RemoteException wrapping System.ArgumentException: Value does not fall within the expected range. *

  • at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)*
  • at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)*
  • at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)*
  • at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager*)

I am not able to run the robot to open my System1 URL and type the username and password.
Any help is appreciated!

Thanks
Nalini

1 Like

@Nalini_Pendyala

Once check GetApp Credentials.xaml file. This workflow first will try to fetch credentials from Orchestrator and if it’s not found then will try to fetch credentials from Windows Credentials Manager and if here also not found then it will ask us to enter the credentials.

Note: It will ask us enter the credentials in first run only and once you entered credentials it will be saved into Windows Credentials Manager. Next time onwards it will read credentials from Windows Credentials Manager directly.

Could you show me screenshot of how you passed value to Open Browser activity. Need to check once.

2 Likes

Lakshman
Thanks for the prompt response! Really appreciate it!
I am attaching a word doc with few screenshots. Please have a look at them.
Also the Credential Asset I created in Orchestrator is “System1Credential”. Same name and value I gave in Config file.
But in Invoke Workflow ( getappcredentials.xaml), when I import the arguments, I am passing in_System1Credential( as advised in walkthrough) . Should I pass that directly as “System1Credential” ?
As per your suggestion, while executing the GetAppCredentails.Xaml, the workflow first tries to fetch credentialsfrom Orchestrator. I have given in orchestrator, why does it not fetch for me? Instead it asks for Windows credential? ( confused)
Pls help
Thanks!
NaliniClient HashCode Error.pdf (695.0 KB)

1 Like

Hi @Nalini_Pendyala,

  1. Can you please change the System1Credential to “Settings” tab instead of the Assets.
  2. If you invoked System1LoginProcess.xaml from InitAllApplication.xaml, you can get the Settings value such “in_Config(“System1Credential”).ToString”.

1 Like

Hi KhairulNashran
Thanks for your inputs! I have finally completed the assignment after innumerable runs, tests and tweaks! Uploaded for evaluation.

1 Like