Calculate Client Security Hash system1 login

Hello Team ,

I am working on the assignment 1 for Advanced RPA developer training. If i run the main proces the robot doesn’t write my password and doesn’t write my email and than it click on login. But if i run only system1 login the robot write my password and email and then click login and then it works.

Could any of you guys help me out here .

Thank you

This is what happend if i run the main proces:

@Anass Welcome to the community.

Are you invoking your login workflow from InitAllApplications framework workflow?

1 Like


Can i post my xaml doc here?

1 Like

How are you credentials configured. If you are getting it from the Orchestrator, ensure the config.xlsx file is configured with right variable value. If the config file is ok, check if you are passing in the right config variable.

1 Like

@karavinds Thanks for the tips. I have check the variable en config file everything is good. When i solo run the login proces it works but when i run the main proces the login proces dont typ my email and password. I dont know why it doesnt (506.9 KB)

@Anass, I ran your workflow as is without any changes and it logged in successfully. Check the following.

  1. Ensure the excel config file is closed before you run the task
  2. Ensure the orchestrator credential name is the same as in the config file “ACME_Credential”

The config file is closed and orchestrator credential are the same and it still doesnt work i have made it 3 times.

1 Like

@Anass, what’s the error you see in output pane in Studio? Check if the UiPath Robot is connected to the orchestrator.

1 Like

Thank you for youre time. This is the error that i get

The robot is connected to orchestrator because when i only run the login proces it works. But when i run the main proces i doesnt

Check if you have the right credentials saved in the orchestrator credential entry. I would assume it is because of incorrect username or password, based on the error message.

When you run the login workflow does it prompt you for entering username and password?

1 Like

@karavinds when i run the login proces the robot writes my username and password and clicks login.

When i run the main proces it click on the username and password box but i doesn’t write anything and than click on login. Thats is why i am getting that error

The right credential are saved

Insert a message box or a log entry to check if username or password values are being fetched from the orchestrator. If they are, try adding a delay to see if it helps.

@Anass, pls use debug mode . put breakpoint at activity writing your email into web and run ‘debug’.

did robot throw error or stop on your breakpoint ?

@alex.glebov The robot stops on my breakpoint

1 Like

@karavinds The username and password values dont get fetched from orchestrator whwen i run the main proces. But when i run only the login proces username and password values get fetched from orchestrator

ok had a look at this strange behaviour.

  1. difference between local and call out from main is in … the workflow arguments, which is empty when you run the workflow locally. If you would like to get same results, then you have to add initialisation for arguments exactly what is passed to the workflow when it called from main. I mean value ‘ACME_Credential’ for system1_credential. I expect that the workflow will stop work locally as well as from main.

  2. why script does not enter login details? Because username is null ( see your last screen). ‘Why’ question open still. I have snake suspicious that the asset is broken or empty username is stored in credentials.

screenshot below illustrate local run for workflow and I do not have ACME_Credential asset at all. it does working perfectly without orchestrator.

1 Like

@alex.glebov Thank you for youre help. I am 3 days trying to fix it but it wont work. How can i fix that my username and password = null?

1 Like

Hello @alex.glebov, I could run @Anass successfully without making any changes. I suspect the issue could be with how the asset is created in the orchestrator.

@Anass, please try to delete and recreate the asset in the orchestrator and see it it helps.

Sorry i couldnt react uipath forum has a limit message for new users

@karavinds I have deleted and recreated the asset and it still doesnt work. I think that uipath studio doesnt read the excel config file. Because when i delete the value system1 url(in de arguments) i cant open de browser

1 Like