Please Help! Getting 0/100 for Advanced Assignment 1 but ACME1 is updated correctly!


#1

Please help.
I get 0/100 for Assignment 1 (Client Security Hash)

I have checked the Hash keys generated for the first 3 WIs by entering them manually in sha1 and comparing the results to the results my workflow wrote into ACME1;

Here are the first 3;

XW47730-Shanita Plumber-Italy
4D809F3BE6388C3FA9F5A94385AD455ADA5FBD69 (Done manually via Sha1)
4D809F3BE6388C3FA9F5A94385AD455ADA5FBD69 (by my Workflow and showing on ACME1 comments)

KI44163-Edison Byam-Germany
3CA93AD31779216EEC94933591498EFFDB72FDA4 (Done manually via Sha1)
3CA93AD31779216EEC94933591498EFFDB72FDA4 (by my Workflow and showing on ACME1 comments)

RI52540-Camilla Escarcega-Romania
5A0707B26F6C23EE1C208FE93227165739914EF5 (Done manually via Sha1)
5A0707B26F6C23EE1C208FE93227165739914EF5 (by my Workflow and showing on ACME1 comments)

NB. I have read that we should leave the space between forename and surname, which you can see I have done.

I have not updated or reset the test data since running my workflow and I used the same email address for Uipath Academy and ACME1 system.

When I uploaded my assignment using this;

image

the UPLOAD FILE button allowed me to select the zipped file containing my project folder but then did nothing with the file.
It does say “or” next to it, so I pasted my Youtube link in the field next to it.

In “Name *” field I put my name. (Should this be the project name? if so, should it be “Client Security Hash” or should it match the folder name (“Assignment 1” in my case)

Please help, I am completely stuck now.


#2

Hi @davec,

Instead of zipping entire folder, just zip the main file and attach that file to academy. And, you can give any name.
This is the only difference I could see.
Let us know if this is not working…

Regards,
SP


#3

i have requeste to get detais of client details page in assignment i am getting this error i tried to changing string to uipath.core.genericvalue and uipath.core.genericvalue to string i am getting same error




#4

Santosh,

Thanks for the reply. I tried it like you said but still gives 0/100.

Dave


#5

Hi David,

Was there a requirement to change the status to completed. If so, can you validate if that is accomplished when running your workflow.


#6

Hi PD2,

Thanks for reply.
Yes, the status has been changed to ‘Completed’ for the WIs processed.

edit to add; You can see this happening in the YouTube clip I attached with my first submission.

Dave


#7

i have the same problem too. Can you help me? I would be grateful


#8

Have you attached the youtube link here? Have you tried reset the data first then run your program and then submit it?


#9

Hi Prankurjoshi,

I did reset my data, then I ran my robot, then attached the youtube link when I submitted my form. My ACME1 account is the same email address as my Academy account.

Do you know if there is anything else I can check?

Thanks,
David


#10

hi davec,

Can u pls share the youtube link let me check if any problem exists or not. Also in the ACME website, navigate to the WorkItems page and check all the workitems of WI5 type’s status are set to “Completed”

With Regards,
VP


#11

okay that sounds correct, can you please send me your youtube link just in case we can find something


#12

VP & prankurjoshi,

I have checked again and all WI5 items are set to completed. Here is my youtube link.

I could PM you my email/psw if you want to check my ACME1 test data yourself.

Thanks again,
Dave


#13

First thing, I do not see any login sequence, secondly getting HashCode from SHA1Online is completely missing in the video. Also please make sure there should not be any white space in ClientID-Cilent Name-ClientCountry formula and in it generates wrong hashcode. Only one space should be there between FirstName and LastName of client.

And your sequence before submission must be. Reset the test data, run your program, if it gets completed successfully submit the assignment


#14

When I wrote my login sequence, I found that if I had been logged in within a certain time before, it would jump straight to Dashboard page so I built a flowchart sequence into my workflow to test if already logged in. If not, my robot runs the login sequence. (I have attached the XAML file.) LogInToAcme1.xaml (31.5 KB)

Re sha1 HASH sequence, the window is behind the ACME1 window. It is definitely calculating the correct HASH so it must be using the sha1 generator correctly. is there a setting somewhere to force the sha1 window to appear in front of the ACME1 window when it is being used?

There is no white space in my ClientID-Cilent Name-ClientCountry formula (except the 1 between first name and surname) - I confirmed this by looking at my generated HASH codes and comparing them to ones I got by doing them manually on sha1.


#15

Your program should Logout once you complete the workflow which will help you to login straight everytime. I can guess one more thing starting does not show that you are starting fresh from RE Framework. Lastly I hope you have followed the sequence reset data, run program and submit.

Also if comfortable its better to upload whole workflow instead of Youtube link. After you run program see that each WI5 item is set to completed with HashCode


#16

OK, I will change my workflow to log out of ACME1 before closing the window.

I don’t understand this; “starting does not show that you are starting fresh from RE Framework”. I have the “Main” workflow on display and click the Run button to start. Is this not correct?

Re uploading the workflow, i tried to upload the whole folder when I uploaded my first submission but the upload button wouldn’t attach anything. After evaluation was 0/100, some said to try it with just the Main workflow. That worked but then it wouldn’t let me include youtube link. I think I now understand that it allows only workflow OR youtube link.


#17

No @davec you have to compress your project folder(not only main.xaml) and upload it there. It happens do not worry you will clear this and I am sure you will clear the assignment 2 as well


#18

Thx. Appreciate the help. :smiley:


#19

Ok, I did all as I said and re-submitted with whole workflow folder compressed.

Still get 0/100.

Only thing I can think of now is that in the Main state machine I added an additional Transition from Init -> End with trigger BusinessRuleException isNot Nothing to handle case if no Open WI5 items are found. (it didn’t make sense to me to treat that as a System Exception). Do you know if that would cause a problem with the evaluation? I guessed that even if it did, it should lose the full 100 points. The instructions say that the evaluation is based on “Number of correct items divided by the total number of processed items.”


#20

Hi davec,

Whether you used RE framework for completing your assignment ?