Click Image fails in back office bot

Hi
Whenever I run the bot from the Orchestrator as unattended (that is, VM is signed out), it always fails in click image activities.
However, whenever I execute from local as front end, it works.

Has anyone else faced such issue?

1 Like

Even I’m facing the same issue. When I run the robot through orchestrator also, I’m getting the same click image failure issue saying “Image not found” but works fine with manual run.

I solved this issue by changing the X and Y co-ordinates of image. Due to resolution issues, when robot is running using scheduler (windows or orcehstrator), click is happening outside of image and this has been solved in my robot by adjusting the co-ordinates.

Im having the same problem.

Is there any other way to fix it ? I prefer dont put the exactly coords because maybe the resolution of the VM could change if someone else launch the robot in that VM. It depends.

Any idea ?

The resolution of the machine can be controlled by setting the Resolution settings in UiPath.Settings file, or in 2018.1 by specifying the properties of the robot. https://robot.uipath.com/docs/uipathsettings-file-description

but… why a unattended process fail in click image acitivity?

I dont get why my robot works perfectly in attended mode, and when I launch it in unattended it fails…

I have to solve it

Hi @Pablo_Sanchez,

Make sure the whether the correct screen is appear.

can you take screen shot activity before clicking the image activity.

May be its not went to the screen itself before itself you are getting some issue

Regards,
Arivu

1 Like

Hi @arivu96,

Honestly I cant take a screenshot because it works great when I launch it manually. If i launch it unattended it fails, but I wont be there to take an screenshot.

More than that, the reason of the error that UiPath give to me is: " couldn’t click in text ‘Dat.org.’ ". That’s the text which the robot has to click, and work perfectly unless I launch it unattended. So, thinking in that error, we can suposse that the robot arrives to that screen, but fails in click the text of the image.

Thank you very much.

Regards,

Pablo

1 Like

I have the same problem as @Pablo_Sanchez and I followed your instructions. I wasn’t able to get it working.

Any sugestions?

my suggestion is use click activity instead of using click image… and also choose the Simulate click

Hi @Bernardo_Ferreira,

I solved it using “Launch interactive workflow” activity. With this one, you can select the exact resolution that you want the robot will use in its process, I mean, my process was failing because I launch it in a VM which limits the resolution at 800x600… so with this activity, and checking the propertie “loginToconsole”, my process was launch at 1024x720 and it worked great.

As @rajsekhar says, you can try to use other activites or send hotkeys to navigate through an application, but it will be harded to code, even with an small process…

Hope it could help you guys.
Bests,
Pablo

Hey, sorry to bring up a corpse, but I used orchestrator to ensure the bot/VM ran at the same resolution as my monitor, and it still didn’t work. It can’t find the image to click, but if I log into the VM it will then “see it” and click. Other images work fine, for what it’s worth, this image is the furthest “right” on the screen. The window is maximised and I used 1920x1080 and 1024x720, nothing seems to get it to click this? Was there anything else you did which got this working?
Thanks!

Hey @Alex_Cross

I know what do you mean, tried the same. I recommend you to use Take_Screenshot.xaml (REFramework) where the robot fails.

Doing that you will be sure if the image that robot is trying to click is outside of window. In my experience I would say that the image is outside of limits of the window

Kind regards,
Pablo

Perfect, thanks!! Will try now

@Alex_Cross

if you detect that the image is outside of window, try to move the windowscreen with some activity like “Set Focus” or doing clikc somewhere and then send some “right” hotkeys.

Hope it would help you.

EDIT: You have to put the path where you want to save the screenshot…Import arguments and put the path where the .xaml needs it

Kind regards,
Pablo

So it turns out that the button we want to click is essentially hidden as the ribbon it sits in has been condensed due to a tiny screen resolution. In Orchestrator I changed this to various higher resolutions, but it always failed, so I’m unsure how I can get the screen bigger to make sure the ribbon appears. At least I now KNOW it’s a resolution issue, thanks!

1 Like

Ye, you have to change your screen resolution of your PC at 800x600. Then codify the click using this resolution.

After this run the process

1 Like