Click activity fail when run from orchestrator


I run a process in unattended robot and in my process contains a double click.

When I test in the Studio, the activity is able to double click, however, when I run it from Orchestrator. The double click fail.

Why it fail in the Orchestrator??

Ps: The double click activity is using click image without send window message.
Ps: Just the particular elements contains the problems as others didn’t faced error when run.

Thank you.


Then what is the input method? Simulate or hardware event

hardware event as click image does have stimulate.

And when I change the activity to click activity, the stimulate click return click generic error.
I did publish one version with click activity (also use the hardware event) and it also unable to click using Orchestrator.


I thought you were using modern activity. Check the send window message property in classic double click image activity. Since the workflow is running from orchestrator, it needs background access to work on elements. Otherwise ,use modern click activity and select simulate property.

Hi @g_ii

This might be because of resolution changes… try setting the resolution in your robot to same as your environment. This can be done on orchestrator in robot settings page. And also make sure to have login into console set to false. Manually set it to true and then change to false

As this is image resolution changes might effect


Hi @sangeethaneelavannan1 , @Anil_G

I thinking maybe it’s not the resolution change as other click activity can run successful. :thinking:

Will try the send window message option.

And if later still cannot, maybe can try to use the OCR activity that suggested by friends.

But the way, what is the difference of OCR activity and normal click activity??

Hi @g_ii

Are the other clicks also image based??? Whicha re getting click…there are high chances that because of resolution the required image might be out of the screen bounds also

The different between image click and ocr is that ocr will try to click on the text based on the image that you show or reads image to get the components


Yes, other click activity contains the image based and the selector based one


If you have a take screenshot activity in your flow then try checking it if the required image is visible when the error is thrown


The image is taken and the image is visible when the error is throw.

And I have another question wanted to ask,

My friend suggested me to use OCR because her workflow also unable to use the normal classic click activity, but when using the OCR, the process can run successfully.
Do you know why this happened?

Hello @g_ii

Why are you using the click image activity instead of the normal click activity? Any challenges?

Because click image is not that reliable for background automation. What kind of application are you using?


Because there is a container blocking the element and cause me unable to select it. I tried to check on the UIExplorer there and it is unable to detect.

the application I use is my company’s application, and due to the pnc, I am unable to show.

Hi @g_ii

As an alternative…did you try inspecting the element and check if you can create the selector?

And to answer your question the only difference that i see is click image gives you option to select percentage of match where as ocr decides a best percent for you…


Hi @g_ii are you using the click image activity in the citrix environment?

Tried using the F4 button to change the frame while clicking on the element? If not just give it a try.


Is there have the possible that the click activity is unable to select because the image selected is too small?

And when the process is run unattended, there is minor different with what I selected and since the click activity wanted to get 80% similarity, it causes the problems occur?

I test in my server via remote desktop. And it is also the same machine/environment that will run from orchestrator.

Yes the resolution should be same in both machine i. e where you have developed the code and where you are running the code . Check the image size?

The machine that I develop and run is the same. And before the specific click image, there is other click image which successfully run.

Is it an icon or any text that you want to click?