Click Image Activity not working alternatives

In Citrix application I am using classic click image activity. Kindly note I cannot use CV activities. This sometimes thinks it clicked, but it does not click leaving me with exceptions. Is there any alternative for this like is hover image and sending hot key Enter any better?

Why not? All you need is the UiPath.ComputerVision.LocalServer package installed, and then you don’t even need the cloud connection. And CV is built into the modern activities as a selector type, rather than using the separate CV Scope activities.

That you’re using Click Image tells me you’re still using classic activities. You should be using modern, with Use Application/Browser and then the modern Click which includes image-based recognition. You can adjust the settings to make it more reliable.

Another way to make it more reliable is to use Retry Scope with the Click inside, and set the Click to verify and retry if necessary.


When I tried to use CV Screen scope and indicated on the window, getting an error “Response from server is not valid”

Thank you.

That’s because you’re trying to use the cloud service. You can just do it locally. Install the UiPath.ComputerVision.Localserver package, and then in project settings, set it to use local:

But again, you should also set your project to modern and use the regular Use Application/Browser, Click, Type Into, etc activities as they have CV built in.


Also in Project Settings, you can control which selectors it uses by default. So if your whole automation is in Citrix you can just turn off Strict, Fuzzy, and Image and only use CV:

Or you can control it in each individual activity:


Thank you, @postwick
I have already set local server run and debug to True. Let me reboot my computer and see if the changes take effect.


I am sorry, not finding computer vision in targetting methods. I see UiPath.CV.LocalServer in the Project dependencies list.

Use Application\Browser scope not indicating target application when I indicate because it gives me an error UiPath.RemoteRuntime not installed in the remote.


Just bypass that error. It’ll still get the selector for the Citrix window.

not finding computer vision in targetting methods.

Did you set your project to modern?

Thank you @postwick

Yes, I did. Cannot find CV as target method. For some reason, it is not working.
Resorting to my old image automation. Thank you for all your time.


What version of Studio and UiPath.UiAutomation.Activities are you on?

UiPath activities 20.10.9

Thanks & regards

That’s why. You’re on very old versions.