Click Activity Selector Error Assignment 2

Hi everyone, I’m having issues with a click activity selector in assignment 2. I’ve tried doing the solutions that other people have posted in this forum but I haven’t been able to get anything to work so I could use some help.

The error message I am receiving is: System exception. Retry: 0. Cannot find the UI element corresponding to this selector: at Source: Click Work Item Numbered Page Button

Here is a screenshot of my current workflow and selector:
selector%20error

Thanks!

You selector is not correct. I guess you are doing the next page.

"<webctrl aaname='"+in_TransactionItem.ToString+"' tag='A' class='page-numbers'/>"

That didn’t do the trick for me, I’m still getting an error that it doesn’t like my selector. And I’m not quite sure based on the PDD, should I be passing in_TransactionItem or in_TransactionNumber to the Click activity?

Here is my process workflow if that is easier:
Process.xaml (19.4 KB)

I forgot to add that I was able to copy and paste someone elses code that I found on here into there (it’s currently commented out) and it works, but can’t get my own to work. I’m not sure what the difference is. But even once I get past the current code I’m having issues with, I’m having isssues with my On Element Appears section.

Are you making sure this part is there?
image

Just see the difference in the selector value. I dont think it will be the same

Yeah, you were correct, their selectors were different. I copied over their selectors and now I’m past the click activity.

Not, I’m getting an error on the “On Element Appears” activity that says it’s timing out but I’m assuming it means that the selector is bad for this as well. Here is the screenshot:
selector%20error

1 Like

again the same thing here.
“<webctrl aaname=’”+in_TransactionNumber.ToString+"’ class=‘page-numbers current’ tag=‘SPAN’/>"

And enable the repeat forever to true for this activity if not already

Oops! I sent the wrong screenshot. Here is the correct one :slight_smile:
element%20error

Taking the fact that the next page is in_TransactionNumber +1
i think the value should be +1

Ok, so I redid some of my variables because I dont think I was carrying them right. I know that this process starts in GetTransactionData where argument out_TransactionItem pulls out the current page number into variables TransactionItem which is then taking into the Process workflow I am currently having issues with through argument in_TransasctionItem.

As seen in the previous screenshot, I currently have “1” assigned to in_TransactionItem because I’m just running the Process workflow instead of the entire program for testing.

Now that I’ve fixed my variables, I’m getting this error: On Element Appear ‘A https://acme-test.ui…’ : The selector is not valid

Here is the corresponding screenshot:

If it should still be in_TransactionItem+1, where/how is that written? Does that go in the selector?

ok so the quotes in the selector are not correct. May be due to copy and paste.
Can you remove and type them back and try?

If not how will you dynamically tell that the next page is 2 or 3 when you in_TransactionItem is one
So when you will try element exists page 1 as current page it will not find it.

“<webctrl aaname=’”+(in_TransactionNumber+1).ToString+"’ class=‘page-numbers current’ tag=‘SPAN’/>"

I understand what you’re saying, so I think the easier thing to do will be to just try and run the program from the beginning so that it gets it’s natural values.

I tried to run the program from the beginning but I am receiving an error: Error getting transaction data for Transaction Number: 1. Object reference not set to an instance of an object. at Source: If a new Item is fetched Grab it’s significant data for logging

Here is the screenshot:
gtd%20error

I currently have TransactionNumber set to 1… can you tell me, is it supposed to be set to 1? I tried removing the 1 and leaving TransactionNumber blank but then I received the same error exception it said “Error receiving transaction data for Transacation Number: 0”

Transaction number helps you take the first element in the GetTransactionData where you set the out_TransactionItem that is the TransactionItem,

So 0 or 1 depends how you are accessing your data.

And the error you are getting is because you have not set some argument value in the invoke or inside the get transaction data process

Thanks for the hint - the error is definitely in the GetTransactionData process:
gtd

It’s not entering the fetched if statement because out_Transaction is set to nothing. out_Transaction doesn’t get a value until later on in the workflow. These are the arguments going into the gtd workflow:
gtd%20arguments

Should I give TransactionItem a value of “1”? I feel like that may mess up my program later down the line

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.