Checking Project for validation errors gets stuck

I’ve noticed something and I’m curious if others have this issue, or if the devs are aware of it.
Basically if I make a change to the process, save and quickly press “Debug”, 1/5 times it gets stuck on the validating project message as you can see in the screenshot.

I waited even 10min (just to see how much it takes) and it was still going. Most of the times I just close UiPath and open it again. It gets frustrating after a while though.

Any thoughts on doing some workaround on this? Maybe I can disable some validation options but I don’t know what exactly causes this to freeze.




Hello @MikeStrike ,

Are you facing this for all the projects? Or for a specific project?

You can watch the below reference email. It will help.

Hi @MikeStrike,

A colleague had the same issue yesterday, he restarted his laptop and it seemed to clear it. I’d also recommend looking at the topic that @Rahul_Unnikrishnan has linked, clearing the temp files should help too.

1 Like

@Rahul_Unnikrishnan yes I have seen that thread, also cleaned the Temp file (I do that regularly regardless), Didn’t help solve the issue

@william.coulson you know… I have been going deep into json file trying to see if there are any mismatches there and didn’t even consider the fix that always solves things, a restart. :slight_smile: will try that now.

I’ve also noticed that this issue appears more frequently if I’m working on a source control branch, but can’t confirm it yet.

Thanks for the answers guys.

@MikeStrike Does that mean your project is now synced with a version controller?
Did you faced the same issue, if you are not connected to the VC?

update, the restart seemed to have fixed it for approximately 20 runs
after that it started again,
The issue happens only if I save and quickly do a Debug,
If I save and wait like 5-6 seconds then run debug, it runs well. but my muscle memory always does ctrl+s before running debug.
Also noticed that if I don’t save and just press Debug, it freezes aswell, (since it basically saves before running the process in Debug"

I have a couple of work colleagues who said they experienced this as well but just restarted UiPath.
I guess its not much of an inconvenience but the dev in me really wants to know why this happens :slight_smile:

@Rahul_Unnikrishnan yes, tested it with and without being connected to version control.

will try to reinstall my Uipath Studio altogether and come back with an update later

1 Like

seems like you need to update may be update and check

even after uninstall it still freezes.
@Veera_Raj I have the latest version of UIPath and I updated all my package dependencies
(now I wonder if it might be because of that)

I noticed a new thing: If i go to “Main” process and do “Debug File” it doesn’t freeze
Only if I run “Debug” from tabs other than “Main”
I’m using REF fyi

whenever you debug it will validate extire project ,but if you debug file only it will only validate current xaml , may be try to close all opened xamls before debug , close backround applications
i believe that your windows also updated

I understand, but I can’t close every process tab just to debug the main xaml.
Usually I just select “Debug” from wherever process tab I am in, It works most of the times, it’s just that one time it gets frozen for some unknown reason.

Just tested it again only with Debug File from main, and it froze at the 9th try. I guess I’m left with uninstalling windows at this point :confused:

are you tried with restarting the pc?

the issue may be because of overload , it’s curable one only

yes tried restarting. Doesn’t fix it.
I put the same project on my VM and I didn’t have this issue after almost 50 runs.
Must be something from the windows, so will have to reinstall it in the end.
Weird because the same error was reported by some of my colleagues, and if this happens on a work computer, reinstalling windows is not really an easy fix.
Wish we know what exactly causes this.

@MikeStrike what version of UiPath do you have? We are on 2022.4.1, it has happened a few times to one of the guys in the team now. Wondering if it’s a version specific issue?

Edit: It may be worth raising a UiPath support ticket if the issue persists

I’m using 2022.4.1, same as my colleagues.
Yes, good point. I will raise a ticket, it’s just that I wanted to see if we can figure it out by ourselves first :slight_smile:

1 Like

this is not your code issue , just because of desktop issue its better you contact with desktop support team

1 Like

Now it’s happening every 3rd try, even on the VMs, this is so frustrating, I’ll leave this open here maybe other people have same issue and will come back with an update when I get back from the support

@MikeStrike did you find any solution?

I’m facing the same issue, when i restart the UIPath studio, i can debug the project only one time, then I have to restart the studio again, UIPath Studio version 2022.4.1

1 Like

@Roshan.Manchanayake I did not find a solution just some workarounds but I noticed more and more people have this issue so I assume they will come with a fix soon.

I noticed that for me it happens mostly when I run Debug in Main Process of REF, so I just debug in smaller processes, like “Process” and use “Debug FIle” only, I get maybe one freeze every 30 runs
but if I do Debug all project i get a freeze every 5 runs

I’m waiting to hear from the support


Same issue here. Recently updated the on perm Enterprise Studio, Robot and the Orchestrator to the version 22.4.X. Only fix for me is to close and re-open the Studio. Running everything on the old packages for combability. Looking forward for Support.

I have the same problem since some updates, it is very frustrating since it usually happens when I make a change no matter how small, I already reinstalled uipath and the problem was NOT solved

Uipath version 2022.4.3

1 Like