Chatbot connector issue in orchestrator

Hi,

While executing uipath chatbot there exist an issue in mapped process in uipath chatbot.

I had created agent and intent in dialogflow. Then agent is connected to uipath chatbot. Also orchestrator is connected to chatbot. Then uipath process is published and mapped into intent in uipath chatbot.

After all these steps , when chatbot is tested in web, its showing an error like “Something went wrong, please try again later.”
input parameter is of type string and input argument is also of type string with same name.

After this,When I check orchestrator , the job is still showing pending allocation for user and robot.
How to solve this issue?

Do you have any idea about this?

@rifnanahas - you’ll need to make sure that you have unattended robots connected to orchestrator in the orchestrator folder specified during setup for the job to run.
A way to verify this is to go to try and start a job manually in Orchestrator. To do this, go to the Jobs section in Orchestrator, click on the start button, select a process and a robot to run it on. If you don’t see a robot in the list (see screenshots here: Triggers no search robot?), you’re going to need to add an unattended robot to your folder

Please let me know if you’re able to start a job from orchestrator, but not from your chatbot

1 Like

@Karan - Even I am also facing the same issue (Something went wrong, please check your bot designer) But when I start a job manually in orchestrator it works fine and also I mentioned robot type as unattended.

@dinikokila_k - I’ll need more information to help, but one potential reason might be due to parameter mapping. To confirm whether this is the case, can you please share screenshots of:

  • Parameters of the dialogflow intent

  • Input argument list of the mapped process

If it’s going pending for allocation you have to configure the unattended robot. Go to cmd and type whoamI. You will get domain/username. Password should be your computer pwd. Let me know if it works.

1 Like

Thanks for your input.