Character missing using type into activity

Hi team

Seeking your kind support. I am working on application automation using Click and type Into activity but having issues. I want this automation to work in the background but Input method “Simulate” is not working and throwing an exception as mentioned below while using type into activity

RemoteException wrapping UiPath.UIAutomationNext.Exceptions.InputModeNotSupportedException: Writing text with “Simulate” is not supported for this element.

Tried Input Method “windows message” in type into activity but it is not typing complete text. e.g., I trying to type “Exelon Cisco Deal ID - 55228899” but it is typing "xelon isco eal - 55228899. However, tried to put delays between keys but same issue

Moreover, it’s typing fine with Hardware Event.

Can someone please help me to solve this issue?



Did you try using set text activity?

And is it a web application or a windows application?


It’s window application. Also, tried set Text but it’s not working and giving an exception.

RemoteException wrapping UiPath.Core.ElementOperationException: Member not found. (Exception from HRESULT: 0x80020003 (DISP_E_MEMBERNOTFOUND)) —> RemoteException wrapping System.Runtime.InteropServices.COMException: Member not found. (Exception from HRESULT: 0x80020003 (DISP_E_MEMBERNOTFOUND))
at UiPath.UiNodeClass.Set(String bstrAttr,
Object vValue)
at UiPath.Core.UiElement.Set(String attribute,
Object value)


Then the only options you have are send windows messages and hardware events…

In send windows mesaages generally casing and all might be removed…and for special characters we have to use as in keyboard some times like to click any special characters we hold shift and type need to follow that

So preferably try hardware events only


Hi @Naresh_Upadhyay Since Hardware Event working fine did you try running in unattended with this option. I believe to run unattended automation, it’s not mandatory to set the simulate/window option. These are required when the robot not able to communicate with the application properly with normal options.


If character missing does not always occur, the following “verify execution function” may help you.
If result text is not same as expected text, it retries to input text.


Tried to run in unattended but got an exception as mentioned below.

RemoteException wrapping UiPath.UIAutomationNext.Exceptions.UiAutomationException: Cannot bring the target application in the foreground. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x800402ea
at UiPath.UiNodeClass.BringIntoView()
at UiPath.NodeExtensions.BringIntoViewAsync(UiNode this)
at UiPath.UIAutomationNext.Services.DriverService.ToForegroundInternalAsync(IUiNodeX uiNode,
Boolean setFocus,
Nullable1 timeout, CancellationToken token) --- End of inner exception stack trace --- at UiPath.UIAutomationNext.Extensions.ExceptionExtensions.GetFriendly(COMException comException) at UiPath.UIAutomationNext.Extensions.ExceptionExtensions.ThrowFriendly(COMException comException) at UiPath.UIAutomationNext.Services.DriverService.ToForegroundInternalAsync(IUiNodeX uiNode, Boolean setFocus, Nullable1 timeout,
CancellationToken token)
at UiPath.UIAutomationNext.Services.DriverApplicationService.TryToForeground(ITargetApp targetApp,
IUiNodeX nodeX,
String selector,
Int32 timeout,
CancellationToken token)
at UiPath.UIAutomationNext.Services.DriverApplicationService.AttachToApplication(ITargetApp target,
Int32 findTimeout,
Int32 totalTimeout,
CancellationToken token)
at UiPath.UIAutomationNext.Services.DriverApplicationService.ActivateApplication(ITargetApp target,
CancellationToken token)
at UiPath.UIAutomationNext.Services.DriverApplicationService.ActivateApplicationAsync(ITargetApp target,
CancellationToken token)
at UiPath.UIAutomationNext.Activities.NApplicationCard.GetMainWindowByTargetApp(ActivityContext context,
ITargetApp targetApp,
CancellationToken cancellationToken)
at UiPath.UIAutomationNext.Activities.NApplicationCard.GetRuntimeData(ActivityContext context,
CancellationToken cancellationToken)
at UiPath.UIAutomationNext.Activities.NApplicationCard.ExecuteAsync(NativeActivityContext context,
CancellationToken cancellationToken)
at UiPath.Shared.Activities.AsyncTaskNativeImplementation.BookmarkResumptionCallback(NativeActivityContext context,
Object value)
at UiPath.Shared.Activities.AsyncTaskNativeActivity.BookmarkResumptionCallback(NativeActivityContext context,
Bookmark bookmark,
Object value)
at UiPath.Shared.Activities.ContinuableAsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context,
Bookmark bookmark,
Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context,
Bookmark bookmark,
Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor,
BookmarkManager bookmarkManager)


For now, can you try to turn off Activate property in TypeInto?