Working in notepad in background

hi, i am new in automation. I’m trying to write in the notepad while its run in the back ground but i keep getting error “cannot find the ui element corresponding to this selectors”.
so far first type into activity is working fine. click activity is also working fine for minimising the notepad. but second type into activity keep throwing element.
I don’t know what to do . really need help

Hi there,

If you want to write something in a notepad why dont you try ‘write text file’ activity and revert if you face any issues. This activity is more reliable that UiAutomation :slight_smile:

Have you selected simulate type property in your type into?

But as @Raghavendraprasad suggested, write text file is probably safer and more reliable.

No, but i do select SendWindowMessage property for both TypeInto activity,
and select SimulateClick for Click activity.

Try all as simulate -

also select alter if disabled to true on the type into after minimised.

I have tried this and it works.

no, still not working.
what happening is at first notepad already open in background so first TypeInto activity able to type in it and after click activity performed to minimized notepad window second TypeInto Activity throwing error.

Hi @vipin_kumar,

Could you please try. Second type into in separate attach window.

Omkar P

If you have to go the UiAutomation route then possibly you can use the maximize /activate/set focus activities as standalone or in unison (whichever way it will work out for you - trial and error) and see what is the result.

If you still face issues you can possibly post your xaml / workflow here for us to assess what is going awry. :slight_smile:

thank you for the help

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.